Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm running Ubuntu 12.04 LTS using the Gnome Classic desktop. Under CompizConfig I'm running the Desktop Cube and Wallpaper settings to have a cube with 4 different wallpapers. When using CompizConfig Wallpaper, there are no desktop icons. I can turn them back on via Ubuntu Tweak, but that reverts my wallpaper back to the default on all 4 viewports. Is there a way to have the desktop icons show up while using CompizConfig Wallpaper, or do I just have to choose between having one or the other?

share|improve this question

marked as duplicate by Mitch, Basharat Sialvi, Eric Carvalho, Stephen Myall, Raja May 15 '13 at 13:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Open tweak tool and click, "Desktop" and on the first line there should be the option, "Have file manager manage the desktop" and make sure that it is set to, "on" instead of, "off". If this doesn't work maybe you may have to manually set the icon for the programs on the desktop. This you can achieve by going to your desktop in file manager and right clicking and selecting properties. Then just click on the icon of the desktop icon and go from there to select a new icon.

share|improve this answer
    
That's under Advanced System Settings, and I've tried that too. Same effect as using Tweak tool to activate the icons. I've tried going to Desktop in my file manager, but there's nothing in it. Clicking on properties only lets me change the icon that represents the Desktop folder in the file manager. I don't see any way of getting the icons to show back up on my actual desktop. –  MugenDraco Nov 19 '12 at 19:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.