Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, in my present location (at work) my Ubuntu machine can't connect to the ethernet. I can see it, meaning that it is listed as an option when I plug in the cable, however the computer never manages to make the connection and eventually gives up. I have no problems connecting to the ethernet at home. Nor is my old computer (also ubuntu, but 12.04) having any problems with this ethernet. At the moment I am connecting to the wifi instead.

From other threads, it seems that this information is called for:

ifconfig:

    eth0      Link encap:Ethernet  HWaddr b8:88:e3:09:5b:5f  
              inet6 addr: fe80::ba88:e3ff:fe09:5b5f/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:28603 errors:0 dropped:504 overruns:0 frame:0
              TX packets:285 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:3659141 (3.6 MB)  TX bytes:74547 (74.5 KB)
              Interrupt:16 

    eth1      Link encap:Ethernet  HWaddr 08:ed:b9:f2:6d:0d  
              inet addr:10.185.116.115  Bcast:10.185.255.255  Mask:255.255.0.0
              inet6 addr: fe80::aed:b9ff:fef2:6d0d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:17746 errors:1 dropped:0 overruns:0 frame:11381
              TX packets:5773 errors:13 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:8212111 (8.2 MB)  TX bytes:798195 (798.1 KB)
              Interrupt:17 

    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:1570 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1570 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:174187 (174.1 KB)  TX bytes:174187 (174.1 KB)

lshw -C network:

    WARNING: you should run this program as super-user.
      *-network               
           description: Ethernet interface
           product: NetLink BCM57785 Gigabit Ethernet PCIe
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: eth0
           version: 10
           serial: b8:88:e3:09:5b:5f
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.123 firmware=sb latency=0 multicast=yes port=twisted pair
           resources: irq:16 memory:b3430000-b343ffff memory:b3440000-b344ffff memory:b3450000-b34507ff
      *-network
           description: Wireless interface
           product: BCM43228 802.11a/b/g/n
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: eth1
           version: 00
           serial: 08:ed:b9:f2:6d:0d
           width: 64 bits
           clock: 33MHz
           capabilities: bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=wl0 driverversion=5.100.82.112 ip=10.185.116.115 latency=0 multicast=yes wireless=IEEE 802.11
           resources: irq:17 memory:b3500000-b3503fff
    WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Any suggestions?

Thanks in advance :)

EDIT: I tried looking at the end of /var/log/kern.log, and got the following:

Nov 21 14:55:36 kaare-Aspire-V3-571G kernel: [  406.122713] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Nov 21 14:55:47 kaare-Aspire-V3-571G kernel: [  416.873347] tg3 0000:02:00.0: eth0: Link is up at 1000 Mbps, full duplex
Nov 21 14:55:47 kaare-Aspire-V3-571G kernel: [  416.873353] tg3 0000:02:00.0: eth0: Flow control is off for TX and off for RX
Nov 21 14:55:47 kaare-Aspire-V3-571G kernel: [  416.873356] tg3 0000:02:00.0: eth0: EEE is disabled
Nov 21 14:55:47 kaare-Aspire-V3-571G kernel: [  416.874342] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

while this was going on, the "quarter-circle" icon in the top corner was doing the "wave" animation, meaning that it was working, and at some point a message came up saying "Wired Network // Disconnected" (in two lines). Does that help anyone?

share|improve this question

closed as too localized by qbi, Ringtail, jrg Jan 21 '13 at 2:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you talk to your network administrator? Maybe the DHCP server only gives IP addresses to known clients (registered MAC addresses). Or maybe there isn't a DHCP server and the IP address have to be manually set. –  Eric Carvalho Nov 21 '12 at 14:38

1 Answer 1

I should embarass myself by revealing the solution:

apparently new hardware has to be registered at my job (using the macaddress), and until then happens it's not allowed to connect. So problem solved, and wasn't caused by Ubuntu.

EDIT: So, yeah, Eric, you got it in one (didn't see your comment until after though). I had already contacted the IT support by email, but they're a bit slow about that.

share|improve this answer
    
You should accept Eric's answer as correct then so he gets the reputation points :-) –  Clive van Hilten Nov 21 '12 at 15:18
    
yes, but how do I accept a comment? –  Kaare Nov 21 '12 at 15:44
    
Ah, you have a good point there - my mistake! –  Clive van Hilten Nov 22 '12 at 7:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.