Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After my lastest update for Ubuntu and Windows XP, I got a Grub error on booting the next day. ls lists the following (without () ):

sd0 sd1, msdos sd2 sd5 sd6 

When I tried to get into one with (sd0,xy)/ it doesn't detect system or unknown file system error.

I tried to boot to a live session with a Knoppix live CD and found out that all data exists. I also tried to recover with TestDisk and it finds all systems. Here is the test disk result:

                          Start        End     Size in sectors
 1 * HPFS - NTFS              0   1  1  7079 254 63  113740137
 2 E extended LBA          7080   0  1 12161 254 63   81642330
 5 L HPFS - NTFS           7080   1  1 10266 254 63   51199092 [Schule]
   X extended             12031  30  1 12161 254 63    2102625
 6 L Linux Swap           12031  31 33 12161 254 63    2102530

I've 1 winxp-home, 1x Ubuntu (ext3+swap) and 1 winxp prof and then I wrote on mbr with TestDisk but I always get the same errors with Grub.

What should I do? I need both XP and Ubuntu. Help me please.

more infos in answers below - sry for thos confusing style but im working on diff live system and browsers and have to reboot always

the boot info script output is also down below

maybe an advanced user can correct my fail posting - after i can solve my issuse i will register here

thanx and pls help me with those weired issues !

as i still cant just comment my own answer or those on top i again has to put it here as a sepperate answer..... (or even edit - maybe an browser failur using the live cds ... cause this posti can edit)

here the bootinfo script output - but the result is the same as with TestDisk ... but it looks worse - cause it also doesnt detect my old ubuntu ... but there wasnt a eares process or overwrite process visibile ending the last working session


                  Boot Info Script 0.61      [1 April 2012]

============================= Boot Info Summary: ===============================

=> Syslinux MBR (4.04 and higher) is installed in the MBR of /dev/sda.

sda1: __________________________________________

File system:       ntfs
Boot sector type:  Windows XP: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  Windows XP
Boot files:        /boot.ini /ntldr /NTDETECT.COM

sda2: __________________________________________

File system:       Extended Partition
Boot sector type:  -
Boot sector info: 

sda5: __________________________________________

File system:       ntfs
Boot sector type:  Windows XP: NTFS
Boot sector info:  According to the info in the boot sector, sda5 starts 
                   at sector 63.
Operating System:  Windows XP
Boot files:        

sda6: __________________________________________

File system:       swap
Boot sector type:  -
Boot sector info: 

============================ Drive/Partition Info: =============================

Drive: sda _______________________________________

Disk /dev/sda: 100.0 GB, 100030242816 bytes 255 heads, 63 sectors/track, 12161 cylinders, total 195371568 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes

Partition Boot Start Sector End Sector # of Sectors Id System

/dev/sda1 * 63 113,740,199 113,740,137 7 NTFS / exFAT / HPFS /dev/sda2 113,740,200 195,382,529 81,642,330 f W95 Extended (LBA) /dev/sda5 113,740,263 164,939,354 51,199,092 7 NTFS / exFAT / HPFS /dev/sda6 193,280,000 195,382,529 2,102,530 82 Linux swap / Solaris

/dev/sda2 ends after the last sector of /dev/sda /dev/sda6 ends after the last sector of /dev/sda

"blkid" output: ____________________________________


/dev/loop0 squashfs
/dev/sda1 6596D86768011128 ntfs
/dev/sda5 1300D3B7744EC141 ntfs Schule /dev/sda6 5b95f2a1-4145-43a5-ac51-41d7dd32b213 swap

================================ Mount points: =================================

Device Mount_Point Type Options

/dev/loop0 /rofs squashfs (ro,noatime) /dev/sr0 /cdrom iso9660 (ro,noatime)

================================ sda1/boot.ini: ================================

[boot loader]



[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptOut

multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect



the last part shows that i now use the windows boot loader so that i can acces at least one OS but shouldnt i also get acces to my ubuntu partitions with live-linux-cds ? or do i have to boot with grub to get to those files only ??

share|improve this question
ugh how do i login to this question - or better register so that i can respond on your answers better ????? i dont wonat to spam my own thread full - and it would be more readable :( ugh well how do u mean - ive 12.04 and a 11. somewhat cd - so i should enter with ubuntu instead of knoppix ? cause under knoppix i should also be able to run grub update ? hm but the problem is i can acces to the ntfs-winxp partitions but cant mount the linux ext3 partitions - i get an error when i use the mnt command but i´ve to say that im a beginner and not quite sure if i used that right – VanceAnce Nov 19 '12 at 12:57
as i mentioned before i cant mount my linux partition and not even see if the data is available neiter with knoppix or ubuntu live cd that is sad - i installed now boot-rescue and made this link: and i also dont get any information about my older ubuntu install - or ist that normal and which sda should i select ? those with win-xp on it ? – VanceAnce Nov 19 '12 at 13:46
bith boot-repair i got win-xp running at least.... but when you klick on the link - why i dont cant find data on my ubuntu drive ??? this is sad :( - what could i do else to get my linux data ? normally wiht an live cd i should be able to get into those drive or not ? – VanceAnce Nov 19 '12 at 13:50
hm sry i couldnt - as my problem is a bootloader problem im trying different things and have to reboot (and not into the acutall session of the first post) - and didnt regerst so far cause i need a solution quick :( - but now as i see it cant get solved quick i should have registerted - and as i replied as VanceAnce user i couldnt add a comment on my own first post :( :( or even edit it - else i would have done it for a better readable post :( - sry for that – VanceAnce Nov 19 '12 at 14:20
you should register your account - this will allow you to edit your question even when the browser cookie is lost. – fossfreedom Nov 19 '12 at 16:37

When you install or update Windows, Windows assumes it's the only OS on the machine—or at least it doesn't account for Linux. So, it replaces GRUB with its own boot loader.

What you have to do is to replace the Windows boot loader with GRUB. Simply chroot into your install and run update-grub.

Here's how you go about it :)

share|improve this answer

If your problem is only with GRUB and it shows GRUB error then insert Ubuntu disk and enter into "Try Ubuntu" then open your terminal and type sudo update-grub (or) if it didn't work then re-install Ubuntu in existing one and the will automatically set.

This works only if your problem is only with GRUB.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.