Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu on my hard drive.

I am not connected to the internet because Ubuntu does not recognize my Atheros AR8161 ethernet.

Therefore I have downloaded a total of 11 files in order to make build-essential and linux headers.

I then use this package to make the driver module:

compat-wireless-3.5.4-1-snpc

Right after I installed Ubuntu, I ran all this and it worked. Ubuntu recognized my driver.

But then when I rebooted everything was gone!

Firstly, I don't want to have to go through all this every time I boot Ubuntu.

Secondly, I did exactly what I did the first time, but now the second time I get error messages.

Here is the output:

http://paste.ubuntu.com/1369897/

You can see from the output that build essential and linux headers are ready to go....I think....maybe I didnt wait long enough?

share|improve this question
add comment

1 Answer

I see where you installed linux-image-3.2.0-34 but linux-headers--3.2.0-33. Please check and correct, if necessary, that you have headers matching your running kernel:

    sudo dpkg -s linux-headers-`uname-r`

Those backticks are on the left side of my US keyboard on the same key with ~.

Then I'd try again including additional steps:

    ./scripts/driver-select restore
    make clean
    ./scripts/driver-select alx
    make
    sudo make install
    sudo modprobe alx

You will need to recompile for a newer running kernel whenever Update Manager installs one using the steps just above.

share|improve this answer
    
OK I am going to change to linux-image-3.2.0-33, but I was running -34 before and it worked. –  Paul Nov 19 '12 at 14:43
    
Are linux-headers-3.2.0-34 not available? –  chili555 Nov 19 '12 at 15:36
    
Well, I have 3 dependencies on linux-headers--3.2.0-33, so it just seemed easiest to change the image to 33. Let me run 33 and see what happens. I don't know how this mix up happened in the first place, but you can see that running after all these dependencies can lead to confusion. –  Paul Nov 20 '12 at 2:41
    
OK, that wasn't a good idea to go ahead with the linux-headers--3.2.0-33 so I went with the linux-headers--3.2.0-34. This produced some errors, but lo and behold the Ethernet was working! I rebooted twice, and it was working both times. So that is progress. I still have problems connecting to internet, which I will post in a separate thread. –  Paul Nov 20 '12 at 9:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.