Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Kubuntu 12.04.01 on a dual-boot computer, I have entered System Settings >File Association to open rtf and richtext files with LibreOffice Writer set as preference over Kate and GNUEmacs. I have several files with .rtf suffix originally created by Windows, although modified and/or renamed by Kubuntu. In spite of my having changed the file association as above, Kubuntu insists on trying to open them from Dolphin with Kate which can't read them properly.

"Open With" is an easy workaround, but I believe Kubuntu should do better. Is it a minor bug,or have I missed something? If a bug is it in Kubuntu, LibreOffice, or Kate?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

At here

Tested with the sample file: http://thewalter.net/stef/software/rtfx/sample.rtf

At here the LO is the default, and working, when opening the rtf format.

The KDE file manager (Dolphin) > Right clik the file > Properties > Click the wrench icon (Edit file type) > Application Preference Order (the first is the LibreOffice Writer).

enter image description here

Something to check

Make a new user, start as a new user. Does the new user have the same problem ?

If with the "new user" file association settings are working then it is possible that with the "old user" file association settings are corrupted (~/.local/share/applications/mimeapps.list).

share|improve this answer
    
THanks user26687, it seems to be behaving itself now. I looked at my rtf file properties and all of them gave Kate aat the top, in spite of LO in FileAssocs. Since all my rtf files had started life in Windows, I wrote some brand new text in LO and saved it as rtf. Dolphin then opened even that in Kate. I logged in as a different user, and it is clear that each user can have different File Associations. The new user had no RTF, so I put one in with LO as the default, and it worked. Back to myself as user and - suddenly it works here. –  WGCman Nov 19 '12 at 20:23
add comment

THanks user26687, it seems to be behaving itself now. I looked at my rtf file properties and all of them gave Kate at the top, in spite of LO in FileAssocs. Since all my rtf files had started life in Windows, I wrote some brand new text in LO and saved it as rtf. Dolphin then opened even that in Kate. I logged in as a different user, and it is clear that each user can have different File Associations, as other changes I had successfully made "as myself" had not migrated to the new account. The new user had no RTF, so I put one in with LO as the default, and it worked. Back to myself as user and - suddenly it works here. The only explanation I can make is that I had originally wrongly set the file association, then somehow fixed the problem before posting this question, but my fix did not take effect until I logged out and back in! I am 30cm tall and my face is red; Sorry and thanks!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.