Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Kubuntu, and want to use Dolphin when I try to save a file or open a new file, but firefox always use Nautilus, how can I change this?

I find this question, but it does not work for me: How can I get Firefox to use Dolphin instead of Nautilus?

I can neither download the kmozillahelper package, nor find the filepicker-variable in my firefox.

my Ubuntu: 12.10
my firefox: 16.0.2

share|improve this question

use dolphin to open folder in firefox

When I installed KDE and Firefox this feature actually worked – I downloaded a file, clicked on “open containing folder”, and Dolphin would happily pop with the respective folder open. However, when I installed a few more apps, Firefox started calling Gwent or other app to “open the folder”.

Solution:

In the file /usr/share/applications/mimeinfo.cache , find “inode/directory” and make “kde4-dolphin.desktop” on first such as:

inode/directory=kde4-dolphin.desktop;kde4-gwenview.desktop;kde4-kfmclient_dir.desktop;

here the Link: http://s8dragon.wordpress.com/2011/01/16/use-dolphin-to-open-folder-in-firefox/

share|improve this answer

For those still having this issue, I found a slightly easier way:

  • Open the Default Applications control module (KDE menu -> search for Default)
  • Select the File Manager list
  • Ensure that Dolphin is selected
    • if it is already selected, reselect by clicking on another option then back to Dolphin
  • click Apply
  • test

This worked for me. YMMV, but this would be a much better solution rather than editing the MIME configuration manually.

Russell.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.