Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a software update on my 64-bit Windows 8 and after restarting my computer, I no longer get my boot menu with Ubuntu 12.10, but instead get a black screen that says:

error: unknown filesystem.
grub rescue>

This is after running boot-repair, which gave me this link: http://paste.ubuntu.com/1369161

I really have no idea what to do. Thank you in advance for any response!

share|improve this question
    
have you tried changing the boot flag to your ubuntu partition? you can do that through a live CD using gparted, select the linux partition, right click then "manage flags" and check the boot flag. –  Sam Nov 19 '12 at 2:34
    
didn't work. The windows partition has a red (!) next to it when I looked at its information, it says cluster accounting failed at (0x4d13e2): extra cluster in $Bitmap. It is the same error two more times for (0x4d13e3) and (0x4d13e4). It says ERROR: NTFS is inconsistent. Run chkdsk /f on windows then reboot twice. I can't even boot into Windows... –  Jose Vergara Nov 19 '12 at 5:00
    
Don't move the boot flag, it is correctly set. –  LovinBuntu Nov 19 '12 at 10:56
add comment

1 Answer 1

  1. Use a Windows disk this way: https://help.ubuntu.com/community/RestoreUbuntu/XP/Vista/7Bootloader , until you get direct access to Windows
  2. Then use Boot-Repair to recover your GRUB menu.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.