Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 10.04 as ftp server, when I upload file using Filezilla client, I always got "550 Permission denied".

How to configure my server?

share|improve this question

migrated from stackoverflow.com Jan 17 '11 at 3:15

This question came from our site for professional and enthusiast programmers.

    
I have changed the permission of my folder to 777 . –  Tom Jan 17 '11 at 12:26
    
What ftp server are you using, and what folder are you trying to push to (e.g. /home/something? /srv/ftp (aka ~ftp)?) –  zpletan Jan 17 '11 at 12:58
3  
Tom, changing the permissions to 777 allows any user to write to the folder. What FTP server software are you using? Where are files stored? Note that FTP is not secured. New setups should use SFTP (over SSH connection; recommended) if possible (FTPS is FTP over a SSL channel which is another hack to make a legacy protocol more secure). –  Lekensteyn Feb 16 '11 at 21:09
    
Actually,I don't know what ftp server software I am using. And I just use this in LAN –  Tom Mar 15 '11 at 5:45
    
Can you give the output of the following command: sudo lsof -i :21? make sure you run this command on the machine that's running the ftp server. –  Weboide Mar 19 '11 at 12:52

5 Answers 5

Probably you has to set the folder's permission for that folder properly For example: If you want to upload a file to folder "testing" using user "MyUser" you have to set write and read permission to MyUser in Testing Folder.

share|improve this answer

The ftp server's settins are likely to be stored in a text file in /etc/name-of-ftp-server/settings-or-similar.conf Open that file with root permissions and edit it, be careful or you'll break your ftp server from working correctly.

The second thing is to check the permissions for the incoming (ex. /var/www or /var/www/incoming if you want to limit upload right to your www server) and outcoming (/var/www )folders which a ftp client would use.

share|improve this answer

You should specify which ftp server you are using. Personally, I recommend ProFTPd. There is a tutorial online on how to set up the server. This server is simple - therefore great for beginners.

share|improve this answer

Don't Use ftp. It is an insecure protocol because it passes login information in the clear.

You should use sftp. Install the package openssh-server

By default this allows root logins, so if you are exposing this system to the internet I would suggest turning off; /etc/ssh/ssh_config PermitRootLogin no

There is a good guide in the Ubuntu documentation; https://help.ubuntu.com/8.04/serverguide/C/openssh-server.html If you can work through the process of using ssh keys to login then disable password authentication then this will greatly enhance the security of your system.

For accessing this from non Linux systems I would recommend either using putty, or winscp

share|improve this answer

I would recommend vsftp. It's easier than proftpd. Installation guides are here http://news.softpedia.com/news/How-to-Install-Vsftpd-in-Ubuntu-45753.shtml or here https://help.ubuntu.com/10.04/serverguide/C/ftp-server.html for example.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.