Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My PC has a 3.5" floppy drive and yes, I do use it. (Retrocomputing hobby.) I use Ubuntu 12.10 with MATE. At every login, the floppy drive lights up and I get the following message box:

Floppy disk error message

The title translates to: It wasn't possible to mount Diskette Disk

Fun fact: If I rmmod floppy and then modprobe floppy while logged in, the same message box appears again.

Also, if I eventually access a floppy disk, the motor won't stop spinning. If I do a mdir of it, after it returns, the motor stops, and then starts again. I suspect there's some process in MATE doing this. My /etc/fstab has nothing related to any removable media, just the root and swap partition.

How do I make MATE stop trying to access the floppy? I repeat, I don't want to disable the floppy. This behavior doesn't happen under CentOS 6 and GNOME 2.x.

share|improve this question

2 Answers 2

Can you uncheck this setting in mateconf-editor: /apps/caja/preferences/media_automount ? On my setup I could stop the SD card automounting after every logon or resume from standby.

share|improve this answer

I'm not sure about the status in the various Ubuntu releases, but upstream mate-conf-editor is obsolete, and now dconf-editor (GUI) or gsettings (command line) are used.

In dconf-editor, the key is org/mate/desktop/media-handling/automount

From the command line: gsettings set org.mate.media-handling automount false

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.