Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I acquired a Dell XPS 1645. Ubuntu seems to run alright on it however The bluetooth is not detected and the WiFi doesn't work. The WiFi is especially weird because I actually have the restricted driver enabled for it. It also worked for a short while when I first booted into Ubuntu however now there isn't even an option to enable wireless.

Both 'etho' and 'lo' return 'no wireless extentions' when running iwconfig and 'sudo ip link set wlan0' returns 'cannot find device "wlan0".

It uses the Broadcom BCM4312 802.11b/g LP-PHY which seems to be contained in plenty of certified Ubuntu systems.

If anyone could possibly help me out with this I'd deeply appreciate it. I've not had to return to Windows for a good while and it's not something I want to have to do now.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Please hook up the ethernet temporarily and do:

    sudo apt-get remove --purge bcmwl-kernel-source
    sudo apt-get install firmware-b43-lpphy-installer

Reboot and let us have your report.

share|improve this answer
    
That seems to have solved everything, thank you very much! Software Sources is showing that I'm not using the proprietary drivers and instead using a manually installed one. Hopefully this will continue to work. Is it still possible to mark problems as solved? –  Ross Nov 19 '12 at 0:55
    
I should also note that although I wasn't expecting it to, this didn't do a thing for the Bluetooth. –  Ross Nov 19 '12 at 1:06
    
I know little about bluetooth. I suggest you post a new question. They only let me fiddle with easy stuff here. –  chili555 Nov 19 '12 at 1:41
    
Thought I should say that I just turned on the laptop and the WiFi no longer works. Either this is only a temporary fix or some sort of update has messed with the drivers. –  Ross Nov 29 '12 at 19:43
    
Does the wireless start if you do: sudo modprobe b43? If so, please do: sudo su; echo b43 >> /etc/modules; exit. –  chili555 Nov 29 '12 at 20:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.