Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Compaq 8710p laptop with a 256MB NVIDIA Quadro 320m was working fine. I switched to the proprietary driver and tried World of Warcraft under WINE until I got unbearable amounts of static. I restarted the computer and the static persisted. I have now moved back to the open source driver and there is now light static that is very annoying.

Picture of the static:

image

share|improve this question
    
Is this your laptop screen or some external monitor? – André Stannek Nov 18 '12 at 23:18
    
@stonedsquirrel This is on my laptop screen. – user98348 Nov 18 '12 at 23:19
    
Strange, now I want to know how this turns out too ;-) – André Stannek Nov 18 '12 at 23:20
    
Got it to work. :) – user98348 Nov 19 '12 at 1:10

If you get this problem, make sure you're on the open source NVIDIA driver through "Software Sources" and restart your computer. Do not log in, instead, let it sit for a bit and the noise should clear up.

share|improve this answer

I was also suffering from heavy static noise problem on my laptop's screen, while using Nvidia's the proprietary drivers.

After navigating through the nvidia-settings options, I realized the culprit of the noise, is the "Temporal Dithering" feature. Look for it under: Display Device (DFP-0 in my case) -> Controls -> Dithering Controls. It is set to Auto (Mode: Temporal) by default.

I played setting the dithering mode, to both Static and Dynamic, and the noise wasn't there anymore. I finally opted for disabling dithering in all my screens, since I don't seem to be suffering from any color banding.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.