Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed the proprietary driver (fglrx-updates) on Ubuntu 12.10 64-bit for my graphics card (ATI Radeon HD 7570). I am using two displays, one connected with DVI, one with HDMI. I set the desktop to be expanded to both screens and disabled the under scan for the HDMI screen, which is always for some reason enabled on HDMI screens.

Now the issue. Everything was fine until I restarted my computer. After reboot, the screen connected with HDMI cable had the black borders again, meaning that the under scan is again enabled. I checked the ATI CCC, and under scan was disabled. However, moving the slider to enable under scan and then back to zero fixed the issue -- temporarily. The same issue is repeated every time I restart my computer. The settings remains the same, but the computer seems to ignore it.

Any ideas how I could solve the issue?

share|improve this question

My dear friend Google helped me out with this. Slightly modifying the command given here made the under scan behave like it should.

Here's the command that solved the issue:

sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
share|improve this answer
thank so much, I had the same problem :) – JoZ3 Dec 26 '12 at 1:44

Before doing:

sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

I also had to do a:

aticonfig --initial

I know, it's kinda obvious, and the error message tells you to - just thought I'd add that here in case someone is similarly concerned because it doesn't work right away.

share|improve this answer

Permanent Fix:
The Catalyst Control Center (GUI) seems to have more than a few problems saving certain user settings and this solution helped me fix one of the more annoying side-effects of using the fglrx proprietary driver in conjunction with an HDMI monitor connection. I ran into a "permission denied' warning when attempting aticonfig --initial so I performed a slight modification to first step:

Open Terminal, then enter the following commands-->

First: (note: I had to use 'sudo')

sudo aticonfig --initial


sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

Additional Temporary Fix:
There is also a hardware/peripheral-side quick fix which depends on the monitor's built-in settings menu. Unfortunately this is a temporary fix which must be done after each system boot, but at least it will get your desktop looking normal-sized while you work on the permanent solution above.

  • Once you have logged into your desktop--> Bring up your monitor's built-in settings menu and look for "Input Select" (or some variation thereof). Depending on your monitor's menu, try to manually re-select HDMI or let it re-scan for connected input. With my Acer 23" for example, I press the MENU button then the INPUT button and the monitor automatically re-selects HDMI after scanning for all possible choices, but now it displays with the correct resolution scaling.
share|improve this answer
sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

You can scale the picture using this command using values 0-9 if it overscans after this setting, just use a value 1-9, like:

sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,5

This is what my computer uses, this way the scaling is done on card and maintains pixel ratios.

(The value is actually the position of the slider in acccle control panel.)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.