Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

OK, have a Toshiba L505 (not sure of the extended model number) that got a virus on Windows and will no longer will boot into that, so I'm trying to revive it with Ubuntu. Problem is, when I tell it to boot into a USB image of 12.04 32- or 64-bit, 13.04 64-bit, or elementary Luna 32-bit, it gives me some screen with a copyright from 2000 for Intel, invariably spits out a "media not recognized" type of error and then says PXE-ROM exiting.

Well, that's annoying.

So I went in with a CD (12.04 x86_64 having tried 32-bit in the past as well). Boot menu, select, starts running. Seeing the loading screen for Ubuntu, going well... until it's not. Again, invariably, it fails. The CD drive will cease spinning at around the same time each time and then the laptop will stop doing everything altogether (at least, everything spins down and it goes quiet). As far as I can tell, it's not to do with what function is being loaded from the CD at the time (because that bit is variable).

I'd love to be able to boot from USB (since it will be all but required going forward), but getting the CD to work would be wondrous too.

Anyone have any ideas of where I can go from here to try to fix this? My friends and I have turned up nothing.

share|improve this question

4 Answers 4

Could be a hardware problem, but first eliminate the obvious:
1) Did you md5sum check the downloaded iso? See https://help.ubuntu.com/community/HowToMD5SUM Check the number against the listing in the link for your release listed at http://releases.ubuntu.com under the MD5SUMS link.
2) If using a CD/DVD, did you burn the disc as slowly as possible? See https://help.ubuntu.com/community/BurningIsoHowto
3) Did you select the media check before trying to install? https://help.ubuntu.com/community/Installation/CDIntegrityCheck
4) Did you ever do a "memory check" (another live-media menu choice) on your PC? Doing the above can save you a lot of time struggling with a bad install media.


unetbootin is what I use to create live media USBs from Windows (or when Ubuntu's startup disk creator does not work for a later ISO). Does your BIOS boot setting have the USB device before the hard disk? At boot time, can you type a function key to select the boot device -- and explicitly select the USB?
When trying the CD, look at the options from the function keys, and select "nomodeset" to avoid some video problems.

share|improve this answer
    
ISO, checked. Burned at lowest speed, check. CD Integrity, checked. Memory check, check. All clear. –  ShroudedCloud Nov 20 '12 at 1:47
    
It just won't boot from the USB drive at all. Not even start to recognize it. I could try to move the boot order, but what I'm doing is going into the select boot device option at startup to select whatever specific drive I'm attempting at the time to ensure it's trying that before Windows. –  ShroudedCloud Nov 21 '12 at 5:32
    
Does the USB boot on another PC? What did you use to create the USB -- how did you do it, since it looks like the USB is non-bootable? –  ubfan1 Nov 24 '12 at 3:22
    
The USB works fine on other computers. Used Startup Disk Creator (or whatever it's called) from on my Ubuntu computer. –  ShroudedCloud Nov 25 '12 at 6:14
    
OK, looks like the USB is fine, so ensure the boot order is changed to put the hard disk below everything else -- sometimes the USB does not have an obvious name -- I've seen USB harddisk, keyondisk, removable media, etc. Try another USB port. It's not a USB3 port is it? Those sometimes don't boot. –  ubfan1 Nov 26 '12 at 17:48

Sounds like a BIOS / hardware issue, not necessarily a Media Problem. Remove the laptop battery and access the memory compartment. While this may or may not work, Remove the SODIMM from the motherboard. You should be able to access the CMOS battery*, remove that also. Leave it out for about 60 seconds (battery) then replace it.

Now, look very carefully within that compartment, you should see a part of the printed circuit board with the letters "pin1-pin2" probably looks like a soldered stub wire of sort. (a small screwdriver or unbent paper-clip works here) Jumper the terminals between pin1 and pin2, hold for about 5-10 seconds. This should have reset the BIOS.

*BTW a new CMOS battery never hurts.

ref

share|improve this answer


A did a quick Google search and found a bug report for a similar issue.

https://bugzilla.kernel.org/show_bug.cgi?id=14679

If your computer has the same problem then the "acpi=copy_dsdt" kernel option may help.

To add the kernel option

  1. Boot off the LiveCD and wait for the boot menu to appear.
  2. Press the F6 button to select 'Other Options'.
  3. Press the escape button, and add the 'acpi=copy_dsdt' option to the end of the line.
  4. Press enter to exit the 'Other Options' menu, and then enter again to 'Try Ubuntu'.

Note: Be cautious when trying new kernel options.

share|improve this answer

I would like to suggest you to upgrade your Bios to latest version, Sometimes Hardware is ready to work but due to old bios there may be problem in data input/output.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.