Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't connect my Alcatel X200 in Ubuntu 12.04 Precise Pangolin. I search some information, and i think is the kernel but i don't know how can i fix it.....

modeswitch work well because the "lsusb" return:

Bus 004 Device 001: ID 1bbb:0000 T & A Mobile Phones

but when i try to add a new connection Ubuntu don't recognize it.

Can somebody help me??


Thank you very much! You has solved the problem that I have three years fixing. but, the connection is "invisible". Is like i'm disconnect, the icon of the connections is a triangle with the top line curve. Is ok? Can i do "visible" the connection?

I can't install nothing in the ubuntu software center, and Ubuntu One doesn't synchronize my files...

Thank you again!

share|improve this question
add comment

1 Answer

OK, try to avoid Network Manager, install and use usb-modeswitch with wvdial instead.

Edit /etc/wvdial.conf as follows:

[Dialer Defaults]
Modem = /dev/ttyUSB1
Baud = 460800
Modem Type = USB Modem
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Phone = *99#
Dial Command = ATDT
Username = INSERT DEFAULT USERNAME HERE (ask Your provider)
Password = INSERT DEFAULT PASSWORD HERE (might me the same, ask Your provider)
Stupid Mode = 1
Dial Attempts = 1

Open a terminal window or switch to another virtual console.

Run sudo wvdial to connect and press Ctrl+C to close the connection.

If this fails you can try substituting other devices for the Modem = /dev/ttyUSB1 line, such as:

/dev/ttyUSB2
/dev/ttyUSB3
...
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.