Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop with broken video card. It has two operating systems installed - Windows 7 and Ubuntu 10.10 Desktop Edition.

It has GRUB to manage which operating system to boot up. Windows is default OS. And Windows fails to boot up without video card. I'm checking with ping to the ports which are shown as used by DHCP in my router.

Normal boot of Ubuntu also fails and it restarts after a while. But when I choose (blindly, but checking HDD indicator and by counting button presses when GRUB menu appears) to boot second option of Ubuntu (rescue mode) it starts and I can ping it. But when I try to connect to it through SSH, I'm getting "connection refused" error from putty.

I've took out HDD from my laptop already and inserted it to WD Passport case so now I can connect it to other computer to edit configuration files.

How can I check if SSH server is working? How to enable it in rescue mode? Or better, how to disable video card to be required while booting Ubuntu in normal mode?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

I'm partially guessing here - this would be a comment if it hadn't been too long for the box - but you could try:

Starting the ssh deamon in rescue mode.

I don't expect this to work, as it may depend on other services that haven't been started yet (rescue mode is a very low-level state with a bare minimum of services running), but it's the quickest: # /etc/init.d/ssh start

As you are working blindly you won't see any error messages, but you can obviously tell that it's working when you can ssh into the box.

Disable the desktop and X server

Since rescue mode works, I'm guessing that the terminal doesn't require a working video card. In that case you should be able to disable anything related to graphics (desktop and X server), and the system might boot to a normal mode terminal-only state. SSH might already be running by then, or you can start it with sudo service ssh start.

I don't have Ubuntu desktop so I can't give details on how to do that, but I believe X server and/or the desktop manager is started as a service. Have a look in /etc/init.d and /etc/init, and see the second reply to this question for how to disable it.

I don't know if this will work, but it might be worth a try.

share|improve this answer
    
Better answer for my problem is here: askubuntu.com/questions/22013/… It's by Stefano Palazzo –  ViliusK Jan 18 '11 at 19:57
add comment

I had the same problem.

Have you tried to reformat your HDD since neither of your OS's are working? At least this way you'll have an interface.

If you install in low graphics mode (or rescue mode) it will install perfectley fine. Thats how I did it with gOS.

To change the resolution to a setting your monitor supports, add "screens and graphics" to your preferences menu and in the monitor settings under generic (or custom ) set to desired resolution. Do not set it to your video card, it will load with distorted graphics or not at all.

Hope this helps, you can email me if you have any questions. I had the same excact problem, my Nvidia crapped out on me on my HP Pavillion laptop. I reformatted and installed gOS in rescue mode and its working beautifuly now.

share|improve this answer
    
With help of Stefano Palazzo, I've managed to start my displayless laptop with broken video card. The answer is in my other question: askubuntu.com/questions/22013/… –  ViliusK Jan 18 '11 at 19:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.