Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I been trying to install skype 4.1 on my ubuntu 11.04 but I have failed, when installing the 32bit package "skype-ubuntu-lucid_4.1.0.20-1_i386.deb" with this command "sudo dpkg -i --force-architecture skype-ubuntu-lucid_4.1.0.20-1_i386.deb"

skype_4.1.0.20-1~raring2_amd64.deb  skype-ubuntu-lucid_4.1.0.20-1_i386.deb
wanas@wanas-Satellite-A500:~/Downloads$ sudo dpkg -i --force-architecture skype-       ubuntu-lucid_4.1.0.20-1_i386.deb
dpkg: warning: overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 178215 files and directories currently installed.)
Preparing to replace skype:i386 4.1.0.20-1 (using skype-ubuntu-lucid_4.1.0.20- 1_i386.deb) ...
Unpacking replacement skype:i386 ...
dpkg: dependency problems prevent configuration of skype:i386:
skype:i386 depends on libasound2 (>> 1.0.22).
skype:i386 depends on libc6 (>= 2.3.6-6~).
skype:i386 depends on libc6 (>= 2.7).
skype:i386 depends on libgcc1 (>= 1:4.1.1).
skype:i386 depends on libqt4-dbus (>= 4:4.5.3).
skype:i386 depends on libqt4-network (>= 4:4.5.3).
skype:i386 depends on libqt4-webkit (>= 4:4.5.3).
skype:i386 depends on libqt4-xml (>= 4:4.5.3).
skype:i386 depends on libqtcore4 (>= 4:4.6.1).
skype:i386 depends on libqtgui4 (>= 4:4.6.1).
skype:i386 depends on libstdc++6 (>= 4.4.0).
skype:i386 depends on libx11-6 (>= 0).
skype:i386 depends on libxext6 (>= 0).
skype:i386 depends on libxss1.
skype:i386 depends on libxv1.
dpkg: error processing skype:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Errors were encountered while processing:
skype:i386

and when I ignore that and Try to open skype through terminal I got this:

wanas@wanas-Satellite-A500:~/Downloads$ skype
skype: error while loading shared libraries: libphonon.so.4: wrong ELF class: ELFCLASS64

I there a way to get it to work, I know that ubuntu 11.04 its support ended last month, and there is no way to get it though the repository. Is there any working ppa works with my distro ?? Thanks in Advance

share|improve this question

closed as off topic by fossfreedom Feb 2 '13 at 10:30

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
FYI: 11.04 is end of life, you should consider upgrading to something more recent :P –  Thomas W. Jan 25 '13 at 4:45

1 Answer 1

Yes, there is. I finished to install on Ubuntu 10.04 64 bits. Follow the instructions:

https://support.skype.com/m/en/faq/FA12120/getting-started-with-skype-for-linux#2.1

The link to download libphonon is old and invalid. This new link is this: http://security.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libphonon4_4.6.2-0ubuntu5.5_i386.deb

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Peachy Nov 20 '12 at 22:14
    
The support is wrong about the LD_LIBRARY_PATH, it should be: LD_LIBRARY_PATH=/home/user/skype-4.1/usr/lib:$LD_LIBRARY_PATH If you already have a 64 bit libphonon, the loader conflicts with it. –  Calmarius Dec 27 '12 at 18:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.