Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this is my own fault. But what i did was this
first i wrote this command 'sudo apt-get remove pulseaudio' and then i wrote again 'sudo apt-get install pulseaudio' and now the sound doesn't work properly
Sound Settings

And the Indicator doesn't work either, it's just grayed out. The shortcuts are not working either.
enter image description here

Alsamixer is working, and this is the only way i change change the volume at the moment:
enter image description here

jeggy@jeggy-XPS:~$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf1c00000 irq 52


jeggy@jeggy-XPS:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
ALSA lib conf.c:1686:(snd_config_load1) _toplevel_:11:0:Unexpected end of file
ALSA lib conf.c:3406:(config_file_open) /etc/asound.conf may be old or corrupted: consider to remove or fix it
/usr/bin/pulseaudio: error while loading shared libraries: libpulsecommon-1.1.so: cannot open shared object file: No such file or directory
card 0: PCH [HDA Intel PCH], device 0: ALC665 Analog [ALC665 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC665 Digital [ALC665 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

VLC sound is not working, am getting this error: enter image description here

share|improve this question
    
Is this a user specific issue or a system wide issue? Create a new account and test with that? Also you've got various comments below with stuff you have tried. Please can you add these back into your question because its quite difficult to follow what you have done. –  fossfreedom Dec 3 '12 at 11:12
    
I had similar problem recently, maybe it would be helpful. –  Vlad K. Dec 5 '12 at 11:40
add comment

4 Answers 4

It seems like I'm unable to comment, so I'm putting my comment into this answer.

Could you open a terminal (Control + Alt + T by default) and enter the command alsamixer? You should see a bunch of volume levels. Make sure they are towards the top of their bars and unmuted ("OO" is unmuted, "MM" is muted at the bottom of each bar).

If it doesn't look like anything's wrong, could you post a screenshot of the alsamixer window?

share|improve this answer
    
jeggy@jeggy-XPS:~$ alsamixer cannot open mixer: No such file or directory –  Jeggy Nov 18 '12 at 21:13
    
Paste output of these: cat /proc/asound/cards, aplay -l, lsmod | grep snd –  Espressofa Nov 18 '12 at 22:56
    
added it to the question –  Jeggy Nov 18 '12 at 23:44
    
I'm not quite sure what's going on, but running the following script could be useful to someone more knowledgeable than me. wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh -- it'll offer to upload the information to their servers for easy sharing if you want, or it can print it. –  Espressofa Nov 19 '12 at 1:14
    
show 2 more comments

When you removed pulseaudio, all packages that depended on it will have been removed. I guess this is the issue.

So, reinstalling pulseaudio alone will not do - it only contains the pulseaudio sound server.

On my comp, searching for pulseaudio in software center returned the following installed packages. Try installing them and see if that solves your problem.

libcanberra-pulse pulseaudio-module-bluetooth pulseaudio-utils pulseadio-module-gconf gstreamer0.10-pulseaudio libpulse0 libpulse-mainloop-glib0 libpulsedsp pulseaudio libsdl1.2debian indicator-sound pulseaudio-module-x11

Of course, you may not need all these packages (gstreamer0.10-pulseaudio for instance).

Alternatively open software center and look into your history. You'll be able to find out what packages were uninstalled along with pulseaudio. Install them and check.

share|improve this answer
    
i got this error 'E: Unable to locate package pulseadio-module-gconf' but then i removed the pulseaudio-module-gconf from there and installed all them successfully, but after rebooting it didn't change anything :( –  Jeggy Dec 2 '12 at 18:28
    
I'm just gonna reinstall Ubuntu –  Jeggy Dec 2 '12 at 19:24
    
pulseudio-module-gconf seems unimportant. Open Software Center > History > Removals > 'The date of uninstall of pulseaudio' and check if something else was removed. My search result may not have returned all dependent packages. –  S Prasanth Dec 2 '12 at 19:24
    
I also tried that, and tried to install them but didn't help either, but i have reinstalled ubuntu now, and now i have 12.10 :D thanks for the help anyway –  Jeggy Dec 2 '12 at 21:09
    
Sorry I couldn't solve your problem. But there are some smart people out there you know. You should probably have waited for the bounty to end, i.e., till your question left the featured section. Doesn't matter now that everything is working. Cheers. –  S Prasanth Dec 3 '12 at 3:15
show 2 more comments

  try this..

open your terminal and type

  sudo apt-get install --reinstall gnome-sound-applet

it will uninstall the gnome-sound-applet and reinstall it.

share|improve this answer
add comment

Check the basic settings are correct:
System tools > System settings > Sound > Output volume to on

share|improve this answer
1  
Sorry but I'm sure OP already checked that. –  Braiam Nov 24 '13 at 15:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.