Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after agree to download and install extra multimedia plugins,

it says package dependency can not be resolved, with below error:

    The following packages have unmet dependencies:

gstreamer0.10-plugins-bad:i386: 
Depends: libc6 (>= 2.15) but 2.15-0ubuntu20 is to be installed
                                Depends: libcairo2 (>= 1.2.4) but 1.12.3+git20120608.f228769d-0ubuntu0ricotz~quantal0 is to be installed
                                Depends: libcdaudio1 (>= 0.99.12p2) but 0.99.12p2-12 is to be installed
                                Depends: libcurl3-gnutls (>= 7.16.2) but 7.27.0-1ubuntu1 is to be installed
                                Depends: libdvdnav4 (>= 4.2.0+20120524) but 4.2.0+20120524-2 is to be installed
                                Depends: libfaad2 (>= 2.7) but 2.7-8 is to be installed
                                Depends: libgcc1 (>= 1:4.1.1) but 1:4.7.2-2ubuntu1 is to be installed
                                Depends: libglib2.0-0 (>= 2.31.8) but 2.34.0-1ubuntu1 is to be installed
                                Depends: libgsm1 (>= 1.0.13) but 1.0.13-4 is to be installed
                                Depends: libgstreamer-plugins-bad0.10-0 (= 0.10.23-7ubuntu1) but 0.10.23-7ubuntu1 is to be installed
                                Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.36) but 0.10.36-1ubuntu1 is to be installed
                                Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.36-1ubuntu2 is to be installed
                                Depends: libmpcdec6 (>= 1:0.1~r435) but 2:0.1~r459-1ubuntu1 is to be installed
                                Depends: libopenal1 (>= 1:1.13) but 1:1.14-4ubuntu1 is to be installed
                                Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-2 is to be installed
                                Depends: libpng12-0 (>= 1.2.13-4) but 1.2.49-1ubuntu1 is to be installed
                                Depends: librsvg2-2 (>= 2.14.4) but 2.36.3-0ubuntu1 is to be installed
                                Depends: librtmp0 (>= 2.3) but 2.4+20111222.git4e06e21-1 is to be installed
                                Depends: libschroedinger-1.0-0 (>= 1.0.9) but 1.0.11-2 is to be installed
                                Depends: libsndfile1 (>= 1.0.20) but 1.0.25-5 is to be installed
                                Depends: libssl1.0.0 (>= 1.0.0) but 1.0.1c-3ubuntu2 is to be installed
                                Depends: libstdc++6 (>= 4.1.1) but 4.7.2-2ubuntu1 is to be installed
                                Depends: libvpx1 (>= 1.0.0) but 1.1.0-1 is to be installed
                                Depends: libxvidcore4 (>= 1.2.2) but 2:1.3.2-9 is to be installed
share|improve this question

1 Answer 1

I had the similar problem.

I solved it by going to the Ubuntu Software Center and installing the following packages:

GStreamer extra plugins
GStreamer ffmpeg video plugin
GStreamer plugins for mms, wavpack,qucktime,musepack

After installing all these packages I could play video without problems.

As far as I understand the system should be able to install the dependent packages by itself but there's a bug

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.