Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Below is the output from my Xorg.0.

X.Org X Server 1.11.3
Release Date: 2011-12-16
[    22.311] X Protocol Version 11, Revision 0
[    22.311] Build Operating System: Linux 2.6.42-23-generic x86_64 Ubuntu
[    22.311] Current Operating System: Linux sean-P55-USB3 3.2.0-34-generic #53-Ubuntu SMP Thu Nov 15 10:48:16 UTC 2012 x86_64
[    22.311] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-34-generic root=UUID=0a34603e-aee9-44d1-8982-a5a5a38c3e4d ro quiet splash
[    22.311] Build Date: 29 August 2012  12:12:33AM
[    22.311] xorg-server 2:1.11.4-0ubuntu10.8 (For technical support please see http://www.ubuntu.com/support)
[    22.311] Current version of pixman: 0.24.4
[    22.311]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    22.311] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    22.311] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov 17 13:20:45 2012
[    22.311] (==) Using config file: "/etc/X11/xorg.conf"
[    22.311] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    22.311] (==) No Layout section.  Using the first Screen section.
[    22.311] (==) No screen section available. Using defaults.
[    22.311] (**) |-->Screen "Default Screen Section" (0)
[    22.311] (**) |   |-->Monitor "<default monitor>"
[    22.311] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[    22.311] (**) |   |-->Device "Default Device"
[    22.311] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    22.311] (==) Automatically adding devices

I have searched all over, and followed lots of dead ends and unanswered questions on this issue. I need to get this monitor recognised so I can use the native resolution of 1600x1200. The Nvidia driver in Windows has no problem with this. The monitor is an old Iiyama HM204DT A. Is there a way of configuring Xorg manually to get these working?

I have tried xrandr but this will not work. Output:-

sean@sean-P55-USB3:~$ xrandr
Screen 0: minimum 8 x 8, current 1152 x 864, maximum 16384 x 16384
DVI-I-0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +
   1360x768       60.0     59.8  
   1152x864       60.0* 
   800x600        72.2     60.3     56.2  
   680x384       119.9    119.6  
   640x480        59.9  
   512x384       120.0  
   400x300       144.4  
   320x240       120.1  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
DVI-I-2 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-I-3 disconnected (normal left inverted right x axis y axis)

Tried Nvidia Xorg.config:

sean@sean-P55-USB3:~$ sudo nvidia-xconfig [sudo] password for sean:

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf. Device section "Default Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.nvidia-xconfig-original' Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup' New X configuration file written to '/etc/X11/xorg.conf'

How do I insert a driver line?

This is a bit of a pain as I want to use my Vectorworks cad program in a WinXP Vbox at 1600x1200 but all virtual drives are restricted to the host screen resolution.

Do i need to manually create EIDI info in Xorg?

I am slightly confused about how Xorg and Nvidia relate

Please help

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Did you try this?

$ sudo apt-get install read-edid
$ sudo get-edid | parse-edid

If so, what is the output of the last command? Does it give an error message?

sean@sean-P55-USB3:~$ sudo get-edid | parse-edid parse-edid: parse-edid version 2.0.0 get-edid: get-edid version 2.0.0

Performing real mode VBE call
Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
Function supported
Call successful

VBE version 300
VBE string at 0x11100 "NVIDIA"

VBE/DDC service about to be called Report DDC capabilities

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
Function supported
Call successful

Monitor and video card combination does not support DDC1 transfers
Monitor and video card combination does not support DDC2 transfers
0 seconds per 128 byte EDID block transfer
Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called Read EDID

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
Function supported
Call failed

The EDID data should not be trusted as the VBE call failed Error: output block unchanged parse-edid: IO error reading EDID

share|improve this answer
1  
OMG not bad for a Noob! Managed to write my own xorg.conf file using the steps found here grenage.com/xorg.html And with the help of my monitor manual and a bit of guesswork All fixed, Can now see all my monitors resolution and refresh rates in Nvidia control panel!! Now reset res to 1600x1200@75 I knew that you can do anything in Linux if you dont give up. –  sean farley Nov 18 '12 at 20:04
add comment

Solution Below Came from answers.launchpad.net:

In the Device section for the video card include the line:

Option "IgnoreEDID" "1"

In the Monitor section include lines for your monitor:

Horizsync 28-100
Vertrefresh 60-76

Values will vary depending upon your monitor, check the docs for it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.