Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Windows 7 x64 installed but after installing Ubuntu 12.10, it asks me to restart but the GRUB loader doesnt even show up, directly boots into Windows What can i do for that ??

share|improve this question
1  
Probably you did not install Grub correctly. Maybe you have chosen the wrong disk where to install Grub. –  To Do Nov 18 '12 at 14:29
    
so where should i exact;y install the grub, i used to do in the same way earlier, it worked –  witcher3 Nov 18 '12 at 16:24
    
See my answer below. Hope it works for you. –  To Do Nov 18 '12 at 16:54

3 Answers 3

try creating ubuntu boot disc/pendrive with SecureBoot

share|improve this answer
1  
Thanks a lot for your answer, but could you please provide step by step instructions for anyone who is unclear about what you're talking about? –  Chris Wilson Dec 3 '12 at 15:10
  1. Boot a liveDVD or liveUSB
  2. Check where Ubuntu is installed. If your Ubuntu partition is on say sda4 then you should install grub on sda without the last digit.
  3. Open a terminal (ctrl + alt + T) an type sudo grub-install /dev/sda changing sda accordingly.

More detailed information here.

share|improve this answer

You can find a site to download a boot repair disc like this http://sourceforge.net/projects/boot-repair-cd/files/ burn it and then start the system. It will repair your boot. Otherwise press the F12 when windows starts and see If Ubuntu is on boot devises.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.