Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an nVidia GeForce and want to send audio output to my television when attaching it via HDMI.. How can I do it?

Thanks in advance

well...

am using an Thomson television and have tried with several desktop envirorments...

share|improve this question
1  
Please include more information, like steps tried, the model of television, the desktop environment, and exactly what is failing. For example, did you check the volume indicator and do you see your TV. –  coteyr Nov 21 '12 at 10:36
    
Might be worth while: install pavucontrol it has several more options that sound settings. I used it for 12.10 once to set it correctly and then sound setting did work correctly too. –  Rinzwind Nov 21 '12 at 14:59
    
pavucontrol doesn't see my hdmi device :-/ –  user1494162 Nov 21 '12 at 16:57
add comment

3 Answers

Yes, in Sound Settings -> Output tab, you can select the HDMI output device and the sound will be directed to HDMI. Choose the appropriate profile in the Mode dropdown menu.

enter image description here

share|improve this answer
    
@Takkat - thanks for the correct translation of the menu names and the picture. Mine is not in English and I am using xfce so my own screen shot wouldn't be very useful. –  laurent Nov 18 '12 at 12:46
    
@Takkat well it isn't there... –  user1494162 Nov 18 '12 at 12:49
    
@user1494162 - the HDMI option is not there? If not, probably your nvidia card is not configured properly. Are you using nvidia proprietary drivers or the open source ones? (both should have the HDMI option). –  laurent Nov 18 '12 at 16:11
    
@Takkat the propietary drivers Nvidia binary Xorg Driver, Kernel Module and VDPAU library ( nvidia-current ) –  user1494162 Nov 18 '12 at 19:14
add comment

you'll have to update the sound card driver. to do that go to system settings > additional drivers > select your sound card driver and click on activate (ref bottom right of the window).

hope this helps.

share|improve this answer
add comment

Just found out the fix for this. Go to alsamixer and unmute S/PDIF
Here is a tutorial

share|improve this answer
3  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Braiam Aug 28 '13 at 12:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.