Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to stop windows from entering into neighbouring workspaces. I would like each window to be self contained inside the current workspace.

Also, how can I stop windows from going underneath the unity bar?

Thank you.

share|improve this question
add comment

1 Answer 1

This is currently a defect in Unity/Compiz. The best you can do is to enable edge stickiness. In ccsm (not installed by default because it's unstable as all get out), go to Window Management and enable "Snapping windows".

Make sure all 4 check boxes are checked and set resistance to 60 and attraction to 20.

This should help you keep your windows on a workstation.

However this is one of those taste things. Some people want things to span like this, others hate it. I personally am in the hate it group. I hope I am wrong, and that someone has a magic answer, but this is the best I have been able to find.

Just to make it clear, this won't stop the behavior, but it will make it a bit easier to manage.

share|improve this answer
    
I really hope I am wrong and some guru can come give us an awesome answer, I find this behavior very annoying and it gets in the way a lot. –  coteyr Nov 18 '12 at 9:01
    
Instead of installing ccsm, you can run this script to achieve the same result. Or manually copy paste those four lines of commands. –  Mahesh Nov 18 '12 at 11:50
    
Thanks your suggestion worked great. I chose 75 and 50 for my own personal preference. –  DonCoryon Nov 18 '12 at 16:43
    
Nice ansewr, but it might be good if "ccsm" was spelled out and it was explained how to install it (sudo apt-get install compizconfig-settings-manager). –  Caleb Feb 6 '13 at 16:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.