Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have exactly the same problem as described here:

So I'll just copy & paste:

I have some weird problems. When I try to log in my Github account, I get a "net::ERR_EMPTY_RESPONSE" error.

I tried with Chrome, Firefox and Opera. In Firefox, if a clean the cache and offline data, it works for a while. Then I can log in, but I still can't create a Github repository, even if I clear the cache again.

My friend, in the same network, with Windows, can do whatever he wants on Github's web site, but I can't. I tried many DNS servers, I tried not to set it (my friend doesn't), but it's still not working.

My OS: Ubuntu x64 12.04

Ideas, please. And thanks.

Also, I can clone any repo but I can't push. I had to change to due to this problem, but I want to understand why it happens.

EDIT: I could clone one repo, but the other one just hangs at this point:

felipelalli@felipelalli-Studio-XPS-8100:~/wa$ git clone
Cloning into 'micaroni'...
remote: Counting objects: 5238, done.
remote: Compressing objects: 100% (3257/3257), done.
Receiving objects:  92% (4839/5238), 43.29 MiB | 902 KiB/s 

ANY push hangs like this:

master!> push
Counting objects: 23, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (15/15), done.
Writing objects: 100% (19/19), 4.25 KiB, done.
Total 19 (delta 3), reused 0 (delta 0)

EDIT 2: I format my PC and I have reinstalled Ubuntu, but the problem keeps the same. So, it eliminates any problem with installations or updates. I have a Dell Studio XPS.

EDIT 3: I pay 4 Bitcoin if anyone solve my problem. Just put your public address together.

EDIT 4: When I try to push, after a few minutes, I receive this message:

felipelalli@felipelalli-Studio-XPS-8100:~/wa/$ git push
Counting objects: 26, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (18/18), done.
Writing objects: 100% (22/22), 4.48 KiB, done.
Total 22 (delta 4), reused 0 (delta 0)
Write failed: Broken pipe
fatal: The remote end hung up unexpectedly
fatal: The remote end hung up unexpectedly
share|improve this question

closed as off-topic by Braiam, Eric Carvalho, Lucio, belacqua, BuZZ-dEE May 19 '14 at 21:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Braiam, Eric Carvalho, Lucio, BuZZ-dEE
If this question can be reworded to fit the rules in the help center, please edit the question.

Felipe - is memcached your issue (…) ? Have you got this installed? – fossfreedom Nov 24 '12 at 12:42
@fossfreedom, no I don't have memcached installed – Felipe Micaroni Lalli Nov 25 '12 at 7:04
if you add -v to your push call (i.e. run in verbose mode) - what is the output? use for your results. – fossfreedom Nov 25 '12 at 9:32
It hangs: – Felipe Micaroni Lalli Nov 26 '12 at 2:41
Was an issue in the server side of GitHub, nothing to do with Ubuntu. – Braiam May 15 '14 at 18:32
up vote 4 down vote accepted

The solution:

after a long thread with Github support, they said it was a server side configuration related to a tentative of avoid DDOS attack that has affected some users, like me. After some adjustments in the Github server everything back to normal and works very fine again!

Thanks very much for Github support team, they were very transparent and helpful.

Quote from the long email thread:

Hi Felipe -

We've been experiencing intermittent DDoS attacks over the last several weeks, and an unfortunate side-effect of some of the preventative measures we've put in place is strange side-effects like this. We believe the problem here was that some of our DDoS protection was mis-configured. We're working with out network provider to tune the DDoS protection to not drop other traffic like this with the highest priority. Sorry again for the repeated problems here!

Jesse GitHub Ops

share|improve this answer
Has there actually been any improvement since then, or are you still having the same problems? – IQAndreas Sep 18 '13 at 19:28
Hi @IQAndreas, I never had this issue before. Have been you? – Felipe Micaroni Lalli Sep 18 '13 at 22:59
I have been getting this issue for close to a year (and I'm still getting it), and reinstalling Ubuntu or adjusting the MTU size has done nothing. Do you think GitHub would be able to help, or should I just continue to use HTTPS? – IQAndreas Sep 18 '13 at 23:06
Hi @IQAndreas! Github should help you! They help me and fix my problem. I am pretty sure your problem is related with some server-side config. Please contact them and put here your story too. It is important to help others having the same issue! Thank you so much. – Felipe Micaroni Lalli Sep 19 '13 at 16:20

Googling around for your error message turns up some stuff about the MTU size.

If possible, I suggest you try a different network/ISP just to confirm it's only happening on that particular network.

Then, you could try changing the MTU (you could for instance see what Windows has for MTU and set Ubuntu's to that; by default it's 1500 on Ubuntu).

Here's how to change MTUs:

I suggest you first check on a different network and only then try to change the MTU. It's not something that needs to be done commonly so if changing networks helps, I'd say it's some weird issue with the network, to which Windows is somehow impervious.

share|improve this answer
Thanks @roadmr! I tried in Mac OSX and Windows and it is fine. Just on Ubuntu I have the problem. I can't even enter in this URL, for example: in Firefox I can access the first page, but fails sometimes when I click inside. I have already tried to change my MTU but still did not work. Do you know what more I can try? I don't understand why Codeplane works and Github does not. Thanks! – Felipe Micaroni Lalli Nov 18 '12 at 5:04
Today, I could enter on but not in for example. The browser keep thinking forever until end on "Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data." – Felipe Micaroni Lalli Nov 19 '12 at 1:55
Well, I can access the machine-gun URL just fine, and I'm running Ubuntu 12.10, so it's not something "wrong" in Ubuntu, just some incompatibility or mismatch with your network and Ubuntu. If the network administrators are reasonable you could ask them for help diagnosing. I fear their usual reply may be "Use Windows" but maybe they can help. – roadmr Nov 19 '12 at 15:30
Hi @roadmr, it happens in my home, and I did the installation from scratch. Maybe it is a problem of my computer (Dell Studio) + Ubuntu 12.10? – Felipe Micaroni Lalli Nov 19 '12 at 19:04

I could help you diagnose it, if you disable all network applications apart from your application (git client in this case) to minimize the network noise and use tcpdump/wireshark to capture the traffic sent and received when you experience problems.

Make sure to start capturing before you run the command that's having trouble connecting.

Install both programs with:

sudo apt-get install wireshark tcpdump

and then run

sudo tcpdump -i wlan0 -o dump.pcap -s 1500

to start capturing before testing.

It would be helpful if you capture the traffic during one session that fails and upload the resulting dump.pcap somewhere where I could download it.

share|improve this answer
thank you. I'll see it as soon as I get in home. But the problem occurs on https, I think it is a problem to tcpdump, isn't it? I'll check if I can test with http. – Felipe Micaroni Lalli Nov 29 '12 at 13:08
I'm not sure what you meant by the problem with tcpdump. I was suggesting to use it to capture all traffic during the time when you experience issues as this would allow to analyse it and possibly find the issue. – Marcin Kaminski Nov 30 '12 at 0:49
I mean https connection is impossible to capture the traffic. Am I wrong? Because it is encrypted. – Felipe Micaroni Lalli Nov 30 '12 at 13:19
My mistake - I didn't notice you were using HTTPS. Even though this wouldn't show you the application level problems that you might be experiencing, you'd still be able to find issues in the lower network layer which might prove to be helpful. – Marcin Kaminski Nov 30 '12 at 15:24
thanks for your attention. So, what should I do now? Worth 4 BTC. – Felipe Micaroni Lalli Dec 1 '12 at 17:11

If you are not behind proxy then ignore this comment.

I am behind proxy at work and had to configure git to reach through it. Before that I had timeouts for github on Ubuntu machine while Windows machines worked fine.

So if you are behind proxy, then open your ~/.gitconfig file and add these lines:

    proxy =
    proxy =

Of course replace IP and port numbers with yours. Hope this helps

share|improve this answer
I'm sorry, this is not my case. Thanks. My main problem still remains, it is when I try to push things to Github. Clone and pull is OK. – Felipe Micaroni Lalli Jan 9 '13 at 13:30

I was getting this error while executing 'brew update' in my command line (terminal):

fatal: unable to access '': SSLRead() return error -36 Error: Failure while executing: git pull -q origin refs/heads/master:refs/remotes/origin/master

I also noticed that none of my browsers were able to connect to the website.

I solved all the connection issues between my mac OS X Mavericks and github by switching my network wifi connection from 802.11n (5.18GHz) to 802.11g (2.412GHz).

I don't know why that worked for me, but I'm just glad it's back to normal.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.