Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ubuntu on Dell Inspiron n4050.I have upgraded to ubuntu 12.04 from 10.04.
But now I find the system startup is a little slow and plymouth only show purple screen without logo during startup.

When I use dmesg, it shows such messages:

    [    2.497750] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
    [    2.603028] usb 2-1.6: new high-speed USB device number 3 using ehci_hcd
    [    2.715538] Initializing USB Mass Storage driver...
    [    2.715594] usbcore: registered new interface driver usb-storage
    [    2.715596] USB Mass Storage support registered.
    [   21.317843] Adding 2000892k swap on /dev/sda5.  Priority:-1 extents:1 across:2000892k
    [   21.323724] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   21.391450] udevd[431]: starting version 175
I wonder what it is doing between 2 second and 21 second. Is it related to being so slow?

I tried bootchart. It gave me a complex picture. Sorry I can't post it here. https://docs.google.com/open?id=0B_U5quEFRFT_a2k1WEZPOEU1Mm8

While ubuntu is booting , I also noticed that it appears:/tmp is not ready or present And sometimes follows *Stop saving kernel messages. Is this the reason dmesg lost output?

share|improve this question

1 Answer 1

Try install bootchart to figure out bottleneck, where the time gap is spent.

http://www.bootchart.org

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.