Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently i bought a Aspire One Acer D270 and i installed Ubuntu 09.10 on it.

Then i tried to connect it with the internet through WiFi and get mad after 8 wasted hours. When i use a wire - it works brilliantly. I realized that Ubuntu does not see my WiFi card.

I googled... Then typed lspci -nn | grep 0280 and get :

Network controller [0280]: Atheros Communications Inc. Device [168c:0032] (rev 01)

I Would greatly appreciate any help, since i really need this netbook during my studies.

I tried also modprobe - literally nothing happend, rfkill NOTHING, no respond
(totally!) lsmod | grep -e wl -e brcm - nothing even changes on the screen.

After sudo iwlist wlan0 scan i get "wlan0 interface doesn't support scanning"

share|improve this question
    
Please add: rfkill list all. Your wireless device uses the driver ath9k and if you have an interface wlan0 then it is no doubt loaded. Check: lsmod | grep ath –  chili555 Nov 18 '12 at 1:23
    
After rfkill list all I do not see any change on the screen. Just nothing. The same after lsmod | grep ath. maybe even with terminal are problems.. –  fdhd Nov 18 '12 at 7:24
    
I tried to download wicd but the message i get is that is was impossible to find packages (even when wired) –  fdhd Nov 18 '12 at 7:42
    
Please run sudo lshw -C network. You should see your ethernet and your wireless. Does your wireless show 'logical name=wlan0' and 'driver=ath9k'? rfkill may not be installed by default in 9.10. Run lsmod and look down the list of loaded modules. Is ath9k among them? –  chili555 Nov 18 '12 at 12:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.