Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

am do this

sudo gedit /usr/share/xsessions/chromeos.desktop

and i file:

[Desktop Entry]
Encoding=UTF-8  
Name=Chrome OS
Comment=
Exec=google-chrome --standalone
Type=Application

in this way am have custom session in lightdm "chrome os" my keyboard input is qwertz but in this session, and in lightdm is qwerty how to change that? and how to expend this session. same thing am trying with play-on-linux becouse am have eee pc with 1.3ghz and 1gb ram

share|improve this question
    
I don't understand what the question is here. Can you explain it a bit more? Are you trying to change your keymap for a specific session? –  mfisch Dec 9 '12 at 4:25
    
quetion is how to change keyboard layout in this session. whem am install ubuntu qwerty is default layout(us). after instalatio, am change my layout in qwertz (serbian, cro), but in lightdm default layout is still qwerty and if am create new user is qwerty too. this "chrome os" session launch chrome in lightdm, like kiosk mode. my resourses is low (1gb ram) and becouse that am doing this. also, am want to create "play on linux" custom sesion in that way. xbmc have this on default –  profiler1982 Dec 9 '12 at 16:50

1 Answer 1

I'm not completely sure if this helps, but it sounds like you still have several keyboard layouts still installed.

First check to see what keyboard layouts you have...

  1. Open the dash (ubuntu main menu).
  2. Type in keyboard layout and open it.
  3. Make sure the keyset you want is only there, if not add it using the + sign button, and remove the other ones with the - sign button.
  4. Also make sure it is the first one on the list by using the arrow buttons.

Now lets check your languages you have installed:

  1. Open the dash again (ubuntu main menu).
  2. Type in language support and open it.
  3. Check to see which language you have as the first option.
  4. Drag the language you want to the start of the list, and then click Apply system-wide button.

If you want the terminal to use your preferred keyboard layout too:

  1. Open up a terminal.
  2. Type in sudo dpkg-reconfigure console-setup to configure it.

Hopefully this should solve your problem.

Note, if you really want English (US) option as well, first make the changes so that they're all German (I'm guessing its German since qwertz is a German keyset), reboot for all the changes to take effect and to confirm everything is working the way you want it... if it is, then go back and add the English (US) keyset back, reboot again to make sure its still working the way you expect.

share|improve this answer
    
this command help: [code]setxkbmap -layout rs,rs,ch,us -variant latin,,,, -model pc105 -option "grp:alt_shift_toggle,grp_led:scroll"[code] but in case of my "chrome os" not becouse in that session am not have terminal. this script change keyboard layout to qwertz –  profiler1982 Dec 25 '12 at 18:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.