Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Note: as per the FAQ, "Issues with the next version of Ubuntu" may not be asked as questions here but in my opinion, this is not an issue but merely a question asking about policy. If you feel this question is off-topic, please leave a comment explaining why or open a question on Meta.AU.

How will Qt 5.0 be packaged for Ubuntu when it is released? Currently, the name of the package for installing the Qt 4.8 core libraries is:

libqt4-core Install libqt4-core

Will the equivalent package for the next version of Qt (5.0) be named libqt5-core? If not, what will the package be named? Will the existing Qt 4.8 libraries coexist with the Qt 5.0 equivalents for the foreseeable future or will they be removed?

The Qt 5.0 beta 2 PPA contains a lot of packages - few of which seem to correspond with existing package names.

If someone can provide me with a link to a policy outlining the Qt 5.0 migration plan, that would be awesome.

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

Library package names in Ubuntu include the major abi version. Some examples are libc6, libkrb5 and libqt4. So the Qt 5.0 libraries will be libqt5-*. Naming them libqt4-* would be wrong as they are not backwards compatible and packages depending on Qt 4.x would suddenly stop working if Ubuntu would do this. Naming the packages libqt5-* (and taking care of possible filename clashes) allows them to be installed simultaneously so you can run Qt 4.x and Qt 5.x apps on the same machine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.