Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of all: I am quite new to Ubuntu (and Linux and servers in all).

When I am trying to install ex phpmyadmin from apt-get, I get the Error:

E: Couldn't configure pre-depend upstart-job for hostname, probably a dependency cycle.

Can anyone tell me why this happens, and what I can do to fix it?

I am running Ubuntu Server 7.10 .

/Christoffer

---EDIT---

I found the problem - and the solution!

I had "ruined" (changed a little) my sources.list -and when I "reinserted" a new one, it all worked!

YUHU!

But thanks for your time, Rupali!

share|improve this question
    
I found the problem - and the solution! I had "ruined" (changed a little) my sources.list -and when I "reinserted" a new one, it all worked! YUHU! But thanks for your time, @Rupali! –  Christoffer D. Brammer Nov 19 '12 at 10:25
add comment

closed as too localized by fossfreedom Nov 19 '12 at 16:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

I had a similar problem honey, running the below command fixed it for me.

sudo dpkg-reconfigure phpmyadmin

Here's the original answer by Srinivas Gowda.

Update: All the errors you got are related due to your old ubuntu distro. phpmyadmin is not compatable with your distro so the only option left is to upgrade.

share|improve this answer
    
The problem is, that it is not only with phpmyadmin - it is everything I try to install.... –  Christoffer D. Brammer Nov 17 '12 at 21:14
    
honey you need to upgrade your O/S isn't it obvious that its absolute. –  Rupali Nov 17 '12 at 21:17
    
Okay - when I try to apt-get install update-manager-core I get this error: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. Since you only requested a single operation it is extremely likely that the package is simply not installable and a bug report against that package should be filed. The following information may help to resolve the situation: –  Christoffer D. Brammer Nov 17 '12 at 21:18
    
The following packages have unmet dependencies: update-manager-core: Depends: python2.7 but it is not going to be installed Depends: python (>= 2.7.1-0ubuntu2) but 2.5.1-1ubuntu2 is to be installed Depends: python-apt (>= 0.7.13.4ubuntu3) but it is not going to be installed E: Broken packages –  Christoffer D. Brammer Nov 17 '12 at 21:21
    
I found the problem - and the solution! I had "ruined" (changed a little) my sources.list -and when I "reinserted" a new one, it all worked! YUHU! But thanks for your time, Rupali! –  Christoffer D. Brammer Nov 17 '12 at 21:29
show 5 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.