Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to install ubuntu-one BUT any time i am trying there is no success! So, any help? Ubuntu studio 12.04 uses XFCE and nautilus as file manager. SO where is the problem?


edit: Well, if i install from terminal then when i start the ubuntu one it starts to install. So, the procedure continues and suddnly the windows closes and then if i try to open again ubuntu one nothing happens.

edit2:When i run ubuntuone-installer from terminal i have

gabriel@gabriel-Desktop:~$ Traceback (most recent call last): File "/usr/bin/ubuntuone-control-panel-qt", line 29, in <module> from ubuntuone.controlpanel.gui.qt import main File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/", line 26, in <module> from ubuntuone.controlpanel.backend import UBUNTUONE_LINK File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/", line 27, in <module> from ubuntuone.platform.credentials import CredentialsManagementTool File "/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/", line 34, in <module> from ubuntu_sso.xdg_base_directory import xdg_home ImportError: No module named xdg_base_directory

edit3: gabriel@gabriel-Desktop:~$ ubuntuone-client ubuntuone-client: command not found

this is what i have when i run ubuntuone-client or sudo ubuntuone-client

share|improve this question

I wrote the following guide a couple of days ago for someone using Mint 12, but the process will be the same.

Installing Ubuntu One Manually

First make sure the system is fully updated.

Open a terminal and use the following command :

sudo apt-get install ubuntuone-installer

When that finishes use the following command to start the installer :


After installation completes, if Ubuntu One is not in the applications menu, open nautilus and go to :


Find the 'Ubuntu One' entry and copy it to your desktop.

Then double click it to open Ubuntu One.

share|improve this answer
any further help? – gabriel Nov 18 '12 at 19:59

First off, did you try using command line AND Synaptic AND Software center (if it exists under Ubuntu Studio)?

For command line, use : sudo apt-get install ubuntuone-client.

For Synaptic, enter ubuntu one in the search bar.

For Software center, search for ubuntu one.

With each method, tell us whatever error message you get if you get any.

EDIT : Seen your edit, try launching the Ubuntu One installation from terminal as sudo by typing sudo ubuntuone-installer. Tell me how it goes.

Thanks, mjchopperboy

share|improve this answer
Look at the edit!thanks – gabriel Nov 17 '12 at 18:34
Lokk at my new edit! – Farid Nov 17 '12 at 18:40
any answer?thanks – gabriel Nov 18 '12 at 9:05
Did you try what I told you to try? How did it turn out? – Farid Nov 18 '12 at 12:24
edit 3....please see that..thanks – gabriel Nov 18 '12 at 19:28

Open terminal and use the following commands:

sudo apt-get install ubuntuone-installer

After that install the ubuntuone-control-panel-qt through terminal

sudo apt-get install ubuntuone-control-panel-qt

This might help you.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.