Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to run update, upgrade or install I always get an error:

Setting up initscripts (2.88dsf-34) ...
Can't exec "insserv": No such file or directory at /usr/sbin/update-rc.d line 391.
update-rc.d: error: insserv rejected the script header
dpkg: error processing initscripts (--configure):
 subprocess installed post-installation script returned error exit status 255
configured to not write apport reports
                                      Errors were encountered while processing:
 initscripts
E: Sub-process /usr/bin/dpkg returned an error code (1)

Previously I tried to upgrade and got a huge error log with this kind of errors:

Preconfiguring packages ...
Setting up initscripts (2.88dsf-34) ...
Can't exec "insserv": No such file or directory at /usr/sbin/update-rc.d line 391.
update-rc.d: error: insserv rejected the script header
dpkg: error processing initscripts (--configure):
 subprocess installed post-installation script returned error exit status 255
configured to not write apport reports
Errors were encountered while processing:
 initscripts
Error in function: 
Setting up acpi-fakekey (0.141-1) ...
Can't exec "insserv": No such file or directory at /usr/sbin/update-rc.d line 406.
update-rc.d: error: insserv rejected the script header
dpkg: error processing acpi-fakekey (--configure):
 subprocess installed post-installation script returned error exit status 255
Setting up kmod (9-2) ...
Can't exec "insserv": No such file or directory at /usr/sbin/update-rc.d line 406.
update-rc.d: error: insserv rejected the script header
dpkg: error processing kmod (--configure):
 subprocess installed post-installation script returned error exit status 255
Setting up dbus (1.6.8-1) ...
Can't exec "insserv": No such file or directory at /usr/sbin/update-rc.d line 406.
update-rc.d: error: insserv rejected the script header
dpkg: error processing dbus (--configure):
 subprocess installed post-installation script returned error exit status 255
dpkg: dependency problems prevent configuration of rhythmbox:
 rhythmbox depends on dbus; however:
  Package dbus is not configured yet.

What's wrong?

share|improve this question
    
It is seems that this is giving the problem sysv-rc : Depends: insserv (> 1.12.0-10) but it is not going to be installed How do I fix this? –  RegedUser00x Nov 17 '12 at 16:19

1 Answer 1

I had the same problem, here: Run this in the terminal

sudo ln -s /usr/lib/insserv/insserv /sbin/insserv

Then run the usual

It solved my problem below, I hope it fixes yours.

Setting up initscripts (2.88dsf-34) ...
Can't exec "insserv": No such file or directory at /usr/sbin/update-rc.d line 406.
 update-rc.d: error: insserv rejected the script header
dpkg: error processing initscripts (--configure):
 subprocess installed post-installation script returned error exit status 255
Errors were encountered while processing:
 initscripts

ln -s /usr/lib/insserv/insserv /sbin/insserv

Then I ran synaptic again

Extracting templates from packages: 100%
Preconfiguring packages ...
Setting up initscripts (2.88dsf-34) ...

I have another error now though

E: /var/cache/apt/archives/
gstreamer0.10-plugins-good_0.10.31-3+nmu1ubuntu1_i386.deb: 
trying to overwrite '/usr/lib/i386-linux-gnu/gstreamer-0.10/libgstcamerabin.so',
which is also in package gstreamer0.10-plugins-bad:i386 0.10.23-7

So I marked gstreamer-bad-plugins for removal in synaptic. So far, so good. Update: It finished with no errors. :D

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.