Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I updated from 12.04(All working) to 12.10 last night and unable to get the wireless driver working properly. It seems to work with no wireless security, but not with WPA. I have tried with other wireless devices and all seems ok.

The laptop is a ASUS X53Z. When I run the following

lspci -nn

I get the following output

03:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)

Hope someone can please help???

share|improve this question

Edit the file


and add this

blacklist acer-wmi

or you might have to do the following:

sudo modprobe -rfv ath9k
sudo modprobe -v ath9k nohwcrypt=1

If that works you can make it permanent:


Add the following line:

options ath9k nohwcrypt=1


share|improve this answer
Hi. Thanks for answering my question. I can dynamically remove and add the driver using and the following and that works. Although I dont have the /etc/modprobe.d/ath9k.conf file. What file should I change? – paul Nov 18 '12 at 10:59
Just created the file, added the line above and rebooted. All works fine. Thanks cprofit – paul Nov 18 '12 at 13:02
glad to know it worked @paul - you should accept the answer so this is marked as solved. – cprofitt Nov 19 '12 at 2:09

even with cprofitt's answer this wasn't solved for me.

My config is HP 450 with ath9k driver.

For me lspci -nn yields same as the OP.

I found from this post that it will be solved if the N-channel (802.11n) is disabled in the router.

Although it may not be feasible to somebody, this is an alternate answer (which is definitely working for me).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.