Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've trolled the internets to make hdmi work on my system Ubuntu 12.04.

  • software center kernel 3.5
  • uname: Linux ubuntu 3.5.0-18-generic #29~precise1-Ubuntu SMP...x86_64 x86_64 x86_64 GNU/Linux
  • open source radeon drivers
  • vgaswitcheroo (hybrid intel/radeon gpu): I boot with intel, not radeon, running. (and recall that with kernel 3.5, vgaswitcheroo now gives info on a third item, "DIS-Audio"; it indicates pwr on my system)
  • /etc/rc.local: chown user:user /sys/kernel/debug/ # change "username" with your user name echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
  • grub indeed now has "radeon.audio=1"

For testing audio, I did:

aplay -l

which gave me the card and device, which made me try

aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav

and lo! I get crystal clear sound on my hdtv.If I play an mp3 file as the argument to that command, I get noise as, I guess, aplay interprets the mp3 code as a wav. If I play a .wav that is not in the /usr/share/sounds/alsa/ directory, I get nothing.

Internet flash video in browser plays no sound over hdmi. Both system sounds control and pavucontrol have hdmi cedar selected. Alas, I can not get sound for any gui test (left, right).

Why would only aplay, and only when directed with -D plughw, yield sound over hdmi? I've also tried only using one sound program at a time, if it was a limitation of alsa, so I tried aplay with web browser and even the sound control gui closed. I tried each of the last two, running alone. No improvement.

alsamixer only shows hda intel and I think it's only the intel audio, not the hdmi.

Edit: kernel 3.6.7 & 3.6.8 (custom compile) allow me to use hdmi audio with any and all programs. Don't know if it's improved support or just the right compile options compared to the 3.5 kernel that's now in the ubuntu repos.

share|improve this question
    
btw, lspci gives: 01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series], and I'm afraid that that radeon card, under hybrid gpu, is not compatible with the fglrx drivers, so they aren't even an option for me (I tried both the canonical extra drivers and building from the latest fglrx download from amd's site, both failed). –  user108754 Nov 17 '12 at 11:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.