Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I start the Ubuntu software centre, it says I cannot do anything until the package catalog is repaired. However, repairing fails.

I ran sudo apt-get -f install and found the problem to be:

mysql-server-5.5 depends on mysql-server-core-5.5 (= 5.5.24-0ubuntu0.12.04.1); however:
  Version of mysql-server-core-5.5 on system is 5.5.28-0ubuntu0.12.04.2.

So, the question is, how do I install that version and resolve the dependency problem?

share|improve this question
    
Did you install anything from source? –  harisibrahimkv Nov 17 '12 at 11:05
    
I had this problem, but really what was needed was a "purge" (from this thread: askubuntu.com/questions/292865/upgrade-mysql-server-issue) –  sceo Jul 7 '13 at 19:16
    
What is the output of apt-cache policy mysql-server-5.5 mysql-server-core-5.5 and cat /etc/apt/sources.list{,.d/*.list} –  Braiam Mar 11 at 23:08
add comment

closed as unclear what you're asking by Braiam, Ask, Warren Hill, BuZZ-dEE, Avinash Raj Mar 13 at 18:03

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

First make sure your package sources are correct. Then run a

sudo apt-get update
sudo apt-get -f install

just to make sure. If that still doesn't work then continue on.

Remove the offending package

sudo dpkg --remove 5.5.28-0ubuntu0.12.04.2

folowed by

sudo apt-get -f install

This should remove MySQL completely (including the meta packages you stated).

You can then re-install with:

sudo apt-get install mysql-server-5.5

share|improve this answer
add comment

I had the same problem with mysql-server-core-5.5 version 5.5.29-0ubuntu0.12.04.1

mysql-server-5.5 depende de mysql-server-core-5.5 (= 5.5.24-0ubuntu0.12.04.1); sin embargo: La versión de `mysql-server-core-5.5' en el sistema es 5.5.29-0ubuntu0.12.04.1

I solved it with this commands:

  1. Backup de database(s)
  2. Check all version avaible of mysql-server for you linux distribution. sudo apt-cache madison mysql-server-5.5.
  3. Remove the packages of mysql-server. sudo apt-get remove mysql-server-5.5 mysql-server-core-5.5.
  4. Install a old version (see the second point for select one). And run the command: sudo apt-get install mysql-server-5.5=5.5.22-0ubuntu1 mysql-server-core-5.5=5.5.22-0ubuntu1
share|improve this answer
add comment

Since I didn't actually need MySQL server anymore I solved this by uninstalling programs with unresolved dependencies one by one.

First I had a similar error:

mysql-server-5.5 : Depends: mysql-server-core-5.5 (= 5.5.29-0ubuntu0.12.04.1)
  but 5.5.29-0ubuntu0.12.04.2 is to be installed

I uninstalled mysql-server-core-5.5 using dpkg:

$ sudo dpkg --remove mysql-server-core-5.5

The another error arised:

mysql-server-5.5 : Depends: mysql-server-core-5.5 (= 5.5.29-0ubuntu0.12.04.2)
  but it is not going to be installed

Uninstall mysql-server-5.5 this time:

$ sudo dpkg --remove mysql-server-5.5

One step higher in the hierarchy:

mysql-server : Depends: mysql-server-5.5 but it is not going to be installed

Uninstall mysql-server:

sudo dpkg --remove mysql-server

Seems to work now.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.