Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently had upgraded my machine from a 12.04 installation to a 12.10 version. I use LaTeX for my publication work and therefore I use TexLive and Kile, both of which are on the Ubuntu Package list.

On my upgrade to the latest version of Ubuntu, the texlive files have mixed up the configurations and therefore the distribution is not able to find the relevant fonts I have used in my earlier documents.

In this context, I downloaded the ISO file for TexLive from the TexLive website first. I then completely removed the texlive package from my system and the directories storing the TexLive configurations. Finally, I mounted the ISO file and installed TexLive on my system. I set the paths according to the recommendations of the installer and therefore the files are now compiling through the use of the command prompt.

However, I prefer Kile as an IDE for latex. Whenever, I try to install Kile it also asks to download the tex-common, texlive-* packages and their corresponding dependencies.

I therefore downloaded the kile package to a local directory by using

apt-get download kile 

and then attempted to install kile by using

sudo dpkg --force-all -i kile*

After this point, the Synaptic Manager tells me that the kile package is broken and it should be repaired by installing the relevant dependencies. The Software Manager also shows its window. How do I stop this from happening, or is there another better IDE for kile? Do have to really go through the painful way of compiling kile from source?

share|improve this question
    
Are you sure you just didn't forgot to install some texlive-* packages? Most fonts are in -recommended and -extra packages. I have no problem at all using TeXLive 2010 with Kile. It is of strong advice to stick with your package management and not to install it from upstream for reasons like this. –  gertvdijk Nov 17 '12 at 9:44
    
A small request: Please read the question carefully. I said, I installed the texlive distribution by using the ISO. –  Indian Nov 17 '12 at 10:15
    
If you want to force installation ignoring dependencies, you should use --ignore-depends flag with dpkg. Maybe it will work for you, but I still don't understand why didn't you just reinstall texlive with apt-get. –  Andrey Nov 17 '12 at 11:04
    
@Indian Yes, that's what I mean. And again: don't do that. Stick with your OS package management to prevent problems you are running into now. –  gertvdijk Nov 17 '12 at 11:13
    
@Andrey: When I upgraded, the texlive package upgraded too. Unfortunately, something was not correct in the Ubuntu packaging and it was not able to locate the fonts any more. So I had to uninstall everything. I did this uninstalling and installing for about 5 to 6 times, all in vain. –  Indian Nov 17 '12 at 11:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.