Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of all Sorry for my poor English.

So my question is, when i want to choose other language to install, it show only English installed [checked], but what i can see in the other post, there have list of languages that allow user to choose. see this print screen

I am a totally new in Linux, What should i do to get the list of languages appear? and why is this happen? Is that because i skipped the language packs during installation? Sorry if this question exist before, i cant find it.

Thanks

share|improve this question
    
What Ubuntu version are you running? In 12.10, under language support, there is a "install/Remove Languages" option. –  Mowgli Nov 17 '12 at 7:44
    
Yes, thats the place i meant, but there are no other languages for me to add, except English –  CT5275 Nov 17 '12 at 7:56
    
see this link –  CT5275 Nov 17 '12 at 8:05
add comment

4 Answers

up vote 1 down vote accepted

Something appears to be missing. It's not the fact that you might have skipped language support at the time of installation as I have an EeePC that I installed without a network connection and I can indeed get to a full language selection screen by clicking the Install/Remove Languages button as per the instructions below.

The only things I can think for you to do at the moment is install the languages individually as suggested by Mowgli, or try to re-install the gnome language selector and see if that fixes the problem:

sudo apt-get --reinstall install language-selector-gnome

You then need to open the language selector from system settings and click on the button Install/Remove Languages. You will get a separate window that opens where you can select additional languages to install.

to get to the language selector

share|improve this answer
    
yup, i know this, but there are no any other languages for me to install except English that is installed by default, see the print screen :( –  CT5275 Nov 17 '12 at 10:54
    
Try re-installing the gnome language selector as per my edit above. –  fabricator4 Nov 17 '12 at 23:34
add comment

Go to system settings, in system settings, go to keyboard layout. in language tab, select any one with bracket. For example:

Chinese
English
English(Australia)
English(Canada)
English(NZ)
English(UK) 
share|improve this answer
add comment

I already resolve it, the main reason why the options are not showing up is because i didn't update it(i skipped updates during installation), so I just simply type in:

sudo apt-get update

after finish update, the languages magically appear, Forgive the Stupid me. D:

share|improve this answer
add comment

I don't know why the options are not coming up. A work-around is to try install languages from the terminal.

The following command will list language packs that can be installed:

apt-cache search language-pack

The packs can be install by entering (for French):

sudo apt-get install language-pack-fr-base
sudo apt-get install language-pack-fr

Replace 'fr' by the language code of your choice found by running the very first command.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.