Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Acer Timeline has a "Disable touchpad button" which works too well. That is, once I've pressed it, pressing it again won't re-enable the touchpad. I've tried a couple of things like:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

which worked once, but now when I do it again, it doesn't work again...

In fact, I'd like to know how to work out what the "disable touchpad" button is actually doing, and why doing it again isn't fixing the issue.

share|improve this question
    
this is a bug in gconf to my memory, I don't think it was fixed :/ –  RolandiXor Jan 26 '11 at 18:56
add comment

3 Answers 3

Just load or unload the psmouse module from kernel

for example:

To disable touchpad:

# rmmod psmouse

To enable touchpad again:

# modprobe psmouse

and voila!

share|improve this answer
    
modprobe psmouse does not turn my touchpad back on –  Seamus Jan 26 '11 at 17:50
add comment

Try 'gconf-editor' from console and enable touchpad from there.

share|improve this answer
2  
Where in gconf-editor is this setting? (You can edit your answer to provide this information.) –  Eliah Kagan Jul 20 '12 at 22:02
add comment

There is a way to do it. When i updated to 11.04 i had this problem. After searching I found a solution. It was by altering some file in the system. What was happening was that the software was disabling the mouse and the hardware was disabling the mouse but once you try to re-enable the mouse the software stays on disable and the hardware works again. All I had to do was make it so that the software keeps the mouse enabled.

share|improve this answer
2  
This answer is not very useful, because it doesn't explain how to do anything, nor does it give any links to resources that would explain it. I recommend editing this to include this sort of information. –  Eliah Kagan Jul 20 '12 at 22:01
    
which file did you changed ? –  sylvainulg Sep 18 '12 at 8:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.