Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently added a PPA (I think it was to change login screen from lightdm to mdm) and ever since then my software centre has stopped working. Whenever I open it I get a "software centre has closed. relaunch?" message. When I try opening it from terminal using software-center it always comes up with this message:

(software-center:19724): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1947:11: Not using units is deprecated. Assuming 'px'.

(software-center:19724): Gtk-WARNING **: Failed to parse /usr/share/themes/mac-os-lion-theme/gtk-3.0/settings.ini: Key file contains line '/* ' which is not a key-value pair, group, or comment
2012-11-16 20:18:20,896 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-11-16 20:18:20,904 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-11-16 20:18:21,910 - softwarecenter.ui.gtk3.app - INFO - show_available_packages: search_text is '', app is None.
2012-11-16 20:18:22,689 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2012-11-16 20:18:25,697 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
2012-11-16 20:18:25,698 - softwarecenter.db.database - INFO - reopen() database
2012-11-16 20:18:25,698 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 243, in open
    self._cache = apt.Cache(GtkMainIterationProgress())
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 102, in __init__
    self.open(progress)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 149, in open
    self._list.read_main_list()
SystemError: E:Type ‘eb’ is not known on line 58 in source list /etc/apt/sources.list
2012-11-16 20:18:28,218 - softwarecenter.db.enquire - ERROR - _get_estimate_nr_apps_and_nr_pkgs failed
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/enquire.py", line 115, in _get_estimate_nr_apps_and_nr_pkgs
    tmp_matches = enquire.get_mset(0, len(self.db), None, xfilter)
  File "/usr/share/software-center/softwarecenter/db/appfilter.py", line 89, in __call__
    if (not pkgname in self.cache and
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 263, in __contains__
    return self._cache.__contains__(k)
AttributeError: 'NoneType' object has no attribute '__contains__'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 176, in <module>
    app.run(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1422, in run
    self.show_available_packages(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1352, in show_available_packages
    self.view_manager.set_active_view(ViewPages.AVAILABLE)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 154, in set_active_view
    view_widget.init_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/availablepane.py", line 171, in init_view
    self.apps_filter)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/catview_gtk.py", line 238, in __init__
    self.build(desktopdir)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/catview_gtk.py", line 511, in build
    self._build_homepage_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/catview_gtk.py", line 271, in _build_homepage_view
    self._append_whats_new()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/catview_gtk.py", line 450, in _append_whats_new
    whats_new_cat = self._update_whats_new_content()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/catview_gtk.py", line 439, in _update_whats_new_content
    docs = whats_new_cat.get_documents(self.db)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 124, in get_documents
    nonblocking_load=False)
  File "/usr/share/software-center/softwarecenter/db/enquire.py", line 317, in set_query
    self._blocking_perform_search()
  File "/usr/share/software-center/softwarecenter/db/enquire.py", line 212, in _blocking_perform_search
    matches = enquire.get_mset(0, self.limit, None, xfilter)
  File "/usr/share/software-center/softwarecenter/db/appfilter.py", line 89, in __call__
    if (not pkgname in self.cache and
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 263, in __contains__
    return self._cache.__contains__(k)
AttributeError: 'NoneType' object has no attribute '__contains__'
share|improve this question

2 Answers 2

Maybe you can run sudo apt-get update and sudo apt-get upgrade from terminal, to see if a newer version of software center is available, thats working again ... Just a guess

share|improve this answer

Try removing the ppa, the /etc/apt/sources.list says there is some problem with the source provided, open /etc/apt/sources.list and remove all entries related to that ppa and then try to open the software center using terminal. Just send the output if errors still exists.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.