Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently whenever I connect an MTP device (my creative zen, or blackberry) rythmbox automatically tries to mount it as a music device and opens up. I just want to be able to connect my device to the usb for charging without having windows popup every time I do.

How can I disable this "autoplay" feature?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

This is probably a better solution (and more likely to work):

  1. Open up the file manager (nautilus)
  2. Click Edit -> Preferences
  3. Click the 'Media' Tab
  4. Next to 'Music Player', select 'Do Nothing' from the drop down list.

The media player should still automount and be available from the 'Places' menu. You will still be able to use Rhythmbox to play/manage the device but you will have to open it up manually.

share|improve this answer
    
FYI There is no Media tab in 14.04. –  pts Nov 17 at 17:32

For Ubuntu and specifically the Zorin Ubuntu derivative: Go to system settings>details, click on details, then click on "removable media", then click the check box "never prompt or start programs on media insertion". This is the easiest way to suppress auto-play via the gui. I suppose there is a way to do this via terminal as well, but my post is for those like me that are more comfortable using the gnome gui instead of terminal.

share|improve this answer

One possible solution:

  1. In Rhythmbox, go to Edit -> Plugins.

  2. Untick 'Portable Players - MTP'.

I'm not sure if this will work and it will probably mean that you have to manually enable the plugin if you want to listen to the device.

share|improve this answer
    
This solution is like crossing the street with a bulldozer. Sure it can work but I rather walk :) –  Dmitriy Likhten Aug 13 '10 at 19:23

For Zune HD, I found "Do Nothing" for "Music Player" (in Preferences for nautilus) was insufficient. I unchecked "Browse media when inserted" and that seemed to solve the problem, allowing me to charge my Zune HD via my Ubuntu laptop USB port without having the thing freeze up, reboot, etc. (Before that, I had tried "Do Nothing" for "Photos" and "Software", but those didn't solve the problem.)

With this solution, I assume it'll be necessary to manually mount CDs and the like when I insert/connect them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.