Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to add some lines which should execute every time Ubuntu boots up, so I don't have to change them manually everytime. I've read in some place that you should edit this file /etc/rc.local. However when I add the lines I want to execute at start up it doesn't run those lines.

So I wonder where the start up file is located in ubuntu? Those lines I want to add is to change the sensitivity for the trackpoint

One of the lines I want to add: echo -n 250 > /sys/devices/platform/i8042/serio1/serio2/sensitivity

share|improve this question
Similar question you might love to have a look at: How to run scripts on start up of ubuntu? – Sid Jan 16 '11 at 14:12
This is likely a duplicate of… – Scaine Jan 16 '11 at 14:24
Also have a look at RcLocalHowto: Ubuntu Documentation – Sid Jan 16 '11 at 14:27
up vote 3 down vote accepted

It's working fine here. Have you made sure that /etc/rc.local ends with "exit 0":


# set trackpoint sensitivity
echo -n 250 > /sys/devices/platform/i8042/serio1/serio2/sensitivity

exit 0

If it does, you're maybe using the wrong path. Try /sys/devices/platform/i8042/serio1/sensitivity instead.

share|improve this answer
@htorque - The problem now it seems the file isn't run at boot up. Instead I have to run it manually with sudo /etc/init.d/rc.local start. Then the trackpointer start to be more responsive. Do you possible know some reason why rc.local isn't executed automatically? – starcorn Jan 16 '11 at 16:35
@starcorn: I'd first test, if it really isn't called during boot. Edit the file to just contain "touch /home/YOURUSER/Desktop/rclocal" and the "exit 0". Then reboot - if you find the file "rclocal" on your desktop, then the script was run and the problem is somewhere else. – htorque Jan 16 '11 at 16:53
@htorque- I have tried adding touch... to the rc.local file now, and the file ends with exit 0. After the reboot the file didn't appear on the desktop. But it will appear if I run the script manually. Where can the problem else be? :( – starcorn Jan 16 '11 at 17:54
Do you have the files /etc/rc*.d/S99rc.local where * is 2-5? – htorque Jan 16 '11 at 18:26
Yes I have that file in rc*.d 2-5 – starcorn Jan 16 '11 at 18:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.