Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i really really hope you can help me here, i just got a 12.04 server set up and running in London and with port changed and ssh [RSA KEY] log in. Then i updated my home pc to 11.10 and cant get connected to the internet. I was going to USB upgrade again to 12.04 but the iso file when booting from pen wants to upgrade using the net for some packages. Bummer.

Some details.

jam@jam-desktop:~$ ifconfig -a 
eth0      Link encap:Ethernet  HWaddr 00:e0:4c:36:07:58   
          BROADCAST MULTICAST  MTU:1500  Metric:1 
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B) 
          Interrupt:25 Base address:0x2000 

lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0 
          inet6 addr: ::1/128 Scope:Host 
          UP LOOPBACK RUNNING  MTU:16436  Metric:1 
          RX packets:456 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:456 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:0 
          RX bytes:35968 (35.9 KB)  TX bytes:35968 (35.9 KB) 

jam@jam-desktop:~$ ifconfig 
lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0 
          inet6 addr: ::1/128 Scope:Host 
          UP LOOPBACK RUNNING  MTU:16436  Metric:1 
          RX packets:456 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:456 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:0 
          RX bytes:35968 (35.9 KB)  TX bytes:35968 (35.9 KB) 

I have searched the net widly on this problem for around 3 days now, and about to scream. lol

more details..

Network says plug UNPLUGGED .. [its not]

In the /etc/network/interfaces

auto lo
iface lo inet loopback

I had been able to force start the connection a few days ago by doing something like.. sudo /etc/init.d/network restart ..... or something along them lines. I still not sure what caused it to start but was playing with this at the time when it started, problem was after doing a reboot it cant find the connection again.

I really need all the help i can get on this, i fallen behind on business, were i should have started building my online shop i find i might have to rebuild this pc and the server. Please help.

share|improve this question
    
sudo dhclient eth0 helps? –  Salem Nov 16 '12 at 21:11
    
jam@jam-desktop:~$ sudo dhclient eth0 [sudo] password for jam: RTNETLINK answers: File exists jam@jam-desktop:~$ thats what i get. –  jamjam Nov 16 '12 at 23:03
    
And i just noticed the internet is back on by doing that sudo... bla bla.. so if i reboot will i have to enter that again? scared to turn it of now. lol thanks for helping bro, nice one. –  jamjam Nov 17 '12 at 0:16
add comment

1 Answer 1

InEdit Connectios make sure the Connection Name is Auto(eth0)ie ethzero-MTU is set to automatic-IP v 4 settings are Method: Automatic(DHCP), both boxes are ticked for 1.Require IP4 addressingfor this connection to complete, and2.Available to all users, In IP v 6 settings, make sure Method: is set to Ignore, and tick the box for Available to all users

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.