Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.10 (Dual boot) on an Imac computer (Intel Core i5, 4GB RAM, AMD Radeon HD 6750 running OS X Lion). THe bluetooth apple keyboard (and mouse as well) are causing a huge headache. The keyboard is not detected when i first install Ubuntu, but then I used the fix described in: http://www.thetechrepo.com/main-articles/520-how-to-connect-an-apple-bluetooth-keyboard-toubuntu-troubleshooting This fixed the problem but only to a certain extent. Here is what the issue is now: On the refit screen the keyboard does not work at all when rebooted from Ubuntu (It does work when rebooted from OS X). When I get to the login screen in Ubuntu, it does connect and I can enter the password perfectly :) However once logged in the keyboard stops working properly, and the buttons get really messed up (My keyboard does not have the NumPad keys and when I press the "i', "o" "p" keys and the ones below it shows them as the Numpad keys (e.g. it prints numbers to the screen). All of the other keys (Enter, Alt, Space and all letters (except the one below the i, o, p, keys) don't work. I am not sure whether these are all due to the same issue, but it is very frustrating. My apple mouse also does not connect properly either and I have to use a wired mouse first to connect the wireless mouse before it works. Is this a common issue is there a simple workaround? Would the previous release Ubuntu 12.04 fix the problem?

Thanks ,

Sam

share|improve this question

1 Answer 1

up vote 8 down vote accepted

The keyboard behaves as a numerical keypad. See this help page.

Quoting here:

Numlock on Apple Wireless Keyboard

If the Apple Wirelesss Keyboard stops working after log-in where most keys do not work and some keys on the right side produce numbers, it is because numlock is enabled by default. Numlock can be switched off by pressing fn-F6 twice. The keyboard then works normally again.

To disable numlock by default, go to System -> Preferences -> Keyboard -> Layout -> Layout Options -> Miscellaneous compatibility options -> turn on "Default numeric keypad keys"

This setting takes effect after logging in and does not affect the graphical login screen or local consoles.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.