Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.10 64bit (clean install) and updated it.

After that i tried to install skype, and i get error that skype depends skype-bin, but it could not install it, and that there are some broken packages!?

In Ubuntu software center there is no skype. And when I try to download it from skype website it installs it via software center and it displays the error that it is not supported because it's i386...

So, how this is possible on clean install of Ubuntu 64bit? And how to fix it? And will someone fix it in next update?

Thanks in advance, Predrag

share|improve this question
    
If you have tried it with 64-bit-package, then remove it again, and try it with 32-bit-package of skype. Don't know if 64-bit-package-feature is meanwhile resolved, but it was similiar problem with earlier package of google-earth and with debian ( there 64-bit-package did not work too - but 32-bit-package was running fine ). –  dschinn1001 Nov 19 '12 at 15:56
    
@dschinn1001: what Predrag is saying is that there's no 64-bit package for Skype. He's running Ubuntu 64-bit. Now I understand why Ubuntu recommends the 32-bit OS... –  Dan Dascalescu Dec 29 '12 at 15:44
add comment

2 Answers

Why don't you try removing it first.

sudo apt-get autoremove skype

Try reinstalling it.

sudo apt-get update && sudo apt-get install skype

What do you get?

EDIT

Try doing

sudo apt-get install skype-bin

before doing the earlier part.

share|improve this answer
2  
'Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: skype : Depends: skype-bin but it is not installable E: Unable to correct problems, you have held broken packages' –  Predrag Nov 16 '12 at 16:04
    
Same error with skype-bin not being installable. –  Dan Dascalescu Dec 29 '12 at 16:03
add comment

This is more of a comment than an answer (because it doesn't provide a solution, since there isn't one at the time) but: there is no functional 64-bit .deb Skype package for Ubuntu 12.10 64-bit. Source: Skype forums.

The package http://download.skype.com/linux/skype-ubuntu_4.0.0.7-1_amd64.deb is "fake" (source: http://www.mindwerks.net/2012/06/skype-4-0-on-ubuntu-precise-12-04-64-bit-2/). Trying to install it will ultimately fail with E: Package 'ia32-libs-multiarch' has no installation candidate

https://help.ubuntu.com/community/Skype is outdated and incorrect - the Canonical partner repo doesn't list Skype.

Summary: you're SOL

share|improve this answer
add comment

protected by Community Nov 19 '12 at 16:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.