Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Foobar2000 volume slider stopped working in Wine

Sound is good but volume cannot be changed from the player's slider anymore.

Is there a setting in Wine that might have entailed this?

I have tested [Vineyard][1] (also) and then gave it up on which occasion some setting in Wine might have been altered but cannot see which.

Edit: This affects the main installation (v.1.1.15) made in Wine, and also portable installations of the same version (as well as portable installations of v.1.1.14 and 1.1.17b that I tested) but does not affect older versions like 1.0.3.

After testing more versions, it seems that the newest version without this problem is 1.1. (That is, before the version that changed the classic white-on-black Foobar2000 icon with the new white one.)

share|improve this question
    
I'm using the most recent stable version downloaded from the site as yesterday (1.1.17) and the volume slider works fine in Wine- have you tried this version for your main installation?. –  user76204 Nov 20 '12 at 22:02
    
the issue is simply related to wine, i guess i should reinstall wine but do not feel like as i have too many apps in there. as i said, FBk2 v.1.1 works fine, so it's just a curiosity, but one that i need to solve anyway for i'll keep using the player.. the problems affects the player according to version not to whether it's main installation or portable. but i'll keep trying what you said. i was thinking about an answer related to a setting in wine –  cipricus Nov 21 '12 at 8:21
    
As for Wine settings, you could try a different Windows compatibility mode. Go to wine > configure Wine > applications > add application and specify a profile for Foobar that uses a different emulation of Windows from the drop down menu like Windows XP, Windows 7, etc. That might be worth trying and can sometimes make a difference for Wine programs. –  user76204 Nov 21 '12 at 11:31
    
just tried that XP/WIN7/8 in 1.1.7 final, no chance for now. i guess it's more hidden in wine: is there a reset setting of wine, as alternative to full re-install? –  cipricus Nov 21 '12 at 12:35
1  
You might be able to use a wineprefix- ie install foobar to a separate wineprefix and thereby have fresh settings- I'll explain in an answer shortly –  user76204 Nov 23 '12 at 0:22
show 1 more comment

2 Answers

up vote 2 down vote accepted
+100

As we have discussed various things in the comments without success, what might work is to create a new wineprefix and then install and run foobar always from that prefix. That may allow you to continue using foobar without reinstalling wine, as the corrupted settings may be present in the original .wine folder.

Create your wine prefix with:

WINEPREFIX=$HOME/.foobar winecfg

Then you can temporarily export the location to the environment:

export WINEPREFIX=$HOME/.foobar

(see my note below re using export and env)

Then cd to your newly downloaded version of Foobar2000 and run the install:

wine foobar2000_v1.1.17.exe

I had to logout and login before I launched the program, or I experienced some odd errors and heavy disk activity. That was probably my system however.

Now if you have logged out, open terminal and run the export command again and then enter

wine "c:\\Program files\\foobar2000\\foobar2000.exe" 

To alter any settings in this new prefix, you can just run

winecfg

as long as the prefix is exported to the environment as above.


Note: I have specified to export the WINEPREFIX environmental variable above; an equally valid method would be to use env, and often using env is very useful as it does not rely on the variable having already been set with export. The WINEPREFIX specified with env is used for that command-line only, whereas using export means that variable becomes the default environmental variable and thus would have to be unset if a different WINEPREFIX was needed to be used.

Some example usage of env:

env WINEPREFIX=$HOME/.special <wine commands>

You will also have to modify the foobar location in the script I recently discussed in my other answer by adding the following, modified for your system, under the shebang at the top of the script:

export WINEPREFIX=$HOME/.foobar
cd /home/mike/.foobar/drive_c/Program\ Files/foobar2000/

This is definitely one way to get fresh settings without reinstalling wine and removing your .wine folder, and it should make foobar work correctly again, and can be repeated for many different wine programs: see the Wine FAQ.

share|improve this answer
    
Thank you for your informative answer, as well as for the other one concerning Thunar custom actions. (By the way, as you seem very knowledgable regarding Wine, could you have a look at this question? (askubuntu.com/q/219650/47206) But sorrily, this here was not a solution for me, I guess thing were more messed up than I thought.The volume would not work even after all the procedure recommended here and I had to finally reinstall Wine: which solved it. But your answer must stay and be rewarded and therefore I'll change the question's title. Or you could edit it if you have the time. –  cipricus Nov 23 '12 at 10:08
1  
@cipricus Thanks- I have had a look at the other question, but I haven't been able to pass any command-line options to searchmonkey and get it properly integrated into Thunar, but will keep trying. –  user76204 Nov 23 '12 at 11:13
add comment

The problem with the volume control appeared for me, too. I changed lots of audio settings in wine and foobar2000, but nothing worked. Then I remembered, that i changed in the wine settings the windows version from Windows XP to Windows 7. Resetting it to Windows XP solved the problem for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.