Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

here is ubuntu 12.10

virtual-box is somehow not working:

I was trying to install win7 on to an usb-hard-disk.

boinc is switched off and RAM-size is set to 4096 MB (too big ? of possible 8 Gibi )

report of virtual-box is:

the com-object for virtualbox could not be created.

the application is now ended.

Start tag expected, '<' not found.

Location: '/home/$user/.VirtualBox/VirtualBox.xml', line 1 (0), column 1.

/build/buildd/virtualbox-4.1.18-dfsg/src/VBox/Main/src-server/VirtualBoxImpl.cpp[484] (nsresult VirtualBox::init()).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Interface:IVirtualBox {c28be65f-1a8f-43b4-81f1-eb60cb516e66}

comment of me: why is virtualbox installing xml into folder of $user in .VirtualBox ? should it not be on usb-harddisk ? (with 500 Gibi )

first installation attempt was breaking off (with win7 in 64Bit) should I try virtual-box (ubuntu 64Bit) with win7 in 32Bit ? should I leave RAM-size of virtual-box to default 512 MB ?

thanks for reply

share|improve this question
up vote 4 down vote accepted

The most simple decision, that i found:

  1. enter into the folder /home/$user/.VirtualBox/
  2. find there file VirtualBox.xml-prev, this is backed up the configurations of Virtual Box
  3. delete VirtualBox.xml
  4. and change name VirtualBox.xml-prev to VirtualBox.xml.
share|improve this answer

Probably due to some updates. It happened to me. A simple command can fix the problem :

sudo /etc/init.d/vboxdrv setup

share|improve this answer

There seems to be nothing wrong with your Virtual Box settings. However the error you see may be related to a previous fail to install Windows leaving unwanted reference to this installation in your Virtual Box settings (that are usually and correctly located in your $HOME).

The issue also may also have come from an installation to a removable drive. Installing the virtual disk .vdi file to an external USB drive is possible but it may lead to unwanted side effects from changed media location or mount points. In addition we then need to make sure the virtualbox user has read and write access to this external drive. Also we obviously should then not access this USB drive from the virtual OS.

To solve the issue you may find a solution in the following question where people recommend reinstalling Virtual Box:

share|improve this answer

The file /home/$user/.VirtualBox/VirtualBox.xml is not valid. It's not valid XML. More then likely you edited the file by hand or some other tool did.

Your ram sizes and everything else seem fine.

Can you pastie the config file, maybe it's something easy we can fix.

share|improve this answer
sorry, for my inconvenience. hmmm, also from beginning new ... I need a formatted hard-disk (usb) with ntfs ? or an empty usb-disk with nothing ? does this ntfs-partition need a partition-table for virtualbox resp. for win7 ? (now virtualbox 4.2.4 is installed with extension-pack for usb - extension pack was missing before) – dschinn1001 Nov 16 '12 at 11:22
forgot to add $user as member for group vboxusers. means then I need 2 entries: 1 $user for usb - harddisk and 1 $user for vboxusers ? – dschinn1001 Nov 16 '12 at 11:36
yeah, now it is solved. and there was "driver-trouble" on different server of Microsoft. the older virtualbox was nagging about full usb-harddisk (it was meant the main harddisk on the system - and I thought usb-harddisk has to be unformatted, but that was wrong). so the actual virtualbox was not nagging and usb-harddisk was formatted with partition-table (for usb-harddisk). - now everything works and this main question is solved. – dschinn1001 Nov 16 '12 at 13:20

I had installed VirtualBox from universal repository, and I solved with this command:

sudo dpkg-reconfigure virtualbox-dkms
share|improve this answer

Run the following commands in terminal:

ls -la .VirtualBox/VirtualBox.xml*
cp .VirtualBox/VirtualBox.xml-prev .VirtualBox/VirtualBox.xml
share|improve this answer
Could you perhaps add more detail to your answer? Explaining what this does and why? Thanks. – Seth Jan 8 '13 at 16:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.