Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get daily crashes with Firefox on Ubuntu. Almost every time I start Ubuntu and then try to launch Firefox, it causes X to crash out immediately. Sometimes I have to log in three or four times before Firefox actually loads. These crashes are obviously causing me to lose any work I haven't saved in other apps. As you can imagine, that is a tad frustrating.

I suspect the crashes might be something to do with the Flash side of things because sometimes when I try to visit a website with Flash content such as bbc iplayer, the dreaded black screen of death appears instantly.

I know that Ubuntu makes modifications to Mozilla's version of Firefox, so I wondered if I could try running a plain Mozilla version of Firefox without modifications to see if that would work. Could anyone tell me how to achieve this?

share|improve this question
    
You can download the latest firefox linux package from Download firefox and run it independently. Please ensure that you have closed the native Firefox before opening this new one. –  saji89 Nov 16 '12 at 7:16
    
Why not google chrome? –  Tachyons Nov 16 '12 at 8:34
    
Why not Google Chrome? For a start it nags me to log in before I start browsing - I do not want that sort of nonsense. Chrome won't run certain plugins that are so useful in Firefox. Chrome seems to have many fewer options than Firefox, and generally it seems to force their way of doing things onto the user. Every time I try it another thing that annoys me crops up, so I've given up on it. Firefox, by contrast, is properly free (as is free from encumbrance). For me, the only good things about Chrome are: the Webkit engine which, I must say, seems fast; and the sandboxed instances. –  dunderhead Nov 16 '12 at 10:28

2 Answers 2

Most likely crashes are caused by plugins, you can try to disable unnecessary plugins.

Try to use flash block plugins to disable Flashes (click to play any flash, in my case, I don't even install Flash for Firefox, I use Chrome's built-in flash module anyway...).

Vanilla version won't really help.

I would recommend backing up your firefox profile

~/.mozilla/firefox/xxxxxxxx.default

Use profile manager to create a new profile and start with that one (you can still switch back and forth)

firefox -profilemanager

http://kb.mozillazine.org/Profile_Manager

If you want to have vanilla Firefox binaries (I don't think it'll help), download from: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/16.0.2/linux-x86_64/en-US/

untar firefox-16.0.2.tar.bz2 to your preferred folder, for example:

cd /opt && tar axvf firefox-16.0.2.tar.bz2

Use ./firefox to start the vanilla Firefox.

share|improve this answer
    
Thanks to all for the replies. I have tried Chrome but so many things about it annoy me that I really do not want to use it. I'll give your flashblock suggestion a look. I didn't mention it in my question but I also get frequent X crashes in other apps, such as Thunderbird but these are a lot less frequent than the ones in Firefox. Recently, trying to launch VirtualBox caused an X crash but that almost never happens. Thanks again –  dunderhead Nov 16 '12 at 9:15
    
Back in 11.04 I did experience Firefox caused X crashes, but not in later releases. Take a look at your ~/.xsession-errors file for error messages (NOTE: it rotates after reboot, so back it up before reboot). –  Terry Wang Nov 16 '12 at 9:22

This might happen due to a lot of reasons. Below, are the things you should try:

  • Download the latest Firefox from the Firefox website. Or atleast make sure that your Firefox version is same as that mentioned on the website.

  • Disable all the plugins. There might be some plugins that are causing the crashes. It happened to me once, and disabling the plugins worked.

    • Disable them by going to Tools > Add-ons.

    • Then, try enabling them one by one, and notice which one causes the crash.

    • Once you've found the notorious one, disable or better remove it. You can also try updating the plugin, if there is a newer version available.

  • Update all the plugins.

    • Go to Tools > Add-ons.

    • Press the settings button, and make sure Update add-ons automatically is checked.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.