Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having the hardest time getting my wireless adapter working on my PC. I actually got it working thanks to the help of another thread (http://ubuntuforums.org/showthread.php?t=1964173&page=2) and a video on the subject (http://www.youtube.com/watch?v=v0Ist9aEKEg&feature=g-hist) but the wireless adapter quit working after a couple days and I seem to be back at square one, only worse.

I've uninstalled Ubuntu and reinstalled it completely and tried the exact same method that got it working before but I keep failing at the same spot.

A little background:

  • My Ubuntu is on a Wubi install I'm using a Netgear WNDA 3100 v2 wireless adapter
  • I've already installed ndiswrapper and have the appropriate .inf and .sys files for the wireless driver.
  • I'm semi-new to linux but know my way around a terminal just fine.

I follow the two tutorials that I mentioned above to a T and everything goes well until I type this command:

sudo modprobe ndiswrapper

The result of that command returns:

Killed

Which did not happen the first time. The first time it returned nothing.

But the real kicker is when I enter

dmesg | grep ndis

I get this bad boy:

    [  179.416769] ndiswrapper version 1.55 loaded (smp=yes, preempt=no)
[  179.731229] ndiswrapper (link_pe_images:575): fixing KI_USER_SHARED_DATA address in the driver
[  179.735417] ndiswrapper: driver bcmn43xx64 (,08/26/2009, 5.10.79.30) loaded
[  179.738211] IP: [<ffffffffa02ceae9>] USBD_InterfaceIsDeviceHighSpeed+0x9/0x20 [ndiswrapper]
[  179.738300] Modules linked in: ndiswrapper(+) nls_iso8859_1 nls_cp437 vfat fat snd_hda_codec_realtek binfmt_misc ppdev fbcon tileblit font bitblit softcursor vga16fb vgastate snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device nouveau ttm drm_kms_helper snd psmouse edac_core serio_raw edac_mce_amd drm i2c_algo_bit soundcore snd_page_alloc lp parport i2c_nforce2 usbhid hid usb_storage sata_nv forcedeth
[  179.738386] RIP: 0010:[<ffffffffa02ceae9>]  [<ffffffffa02ceae9>] USBD_InterfaceIsDeviceHighSpeed+0x9/0x20 [ndiswrapper]
[  179.738574]  [<ffffffffa02bc2aa>] ? NdisAllocateMemoryWithTag+0x1a/0x40 [ndiswrapper]
[  179.738619]  [<ffffffffa02cec70>] ? USBD_InterfaceReference+0x0/0x30 [ndiswrapper]
[  179.738664]  [<ffffffffa02cec40>] ? USBD_InterfaceDereference+0x0/0x30 [ndiswrapper]
[  179.738709]  [<ffffffffa02ceaa0>] ? USBD_InterfaceGetUSBDIVersion+0x0/0x40 [ndiswrapper]
[  179.738754]  [<ffffffffa02cf1c0>] ? USBD_InterfaceQueryBusTime+0x0/0x30 [ndiswrapper]
[  179.738799]  [<ffffffffa02cec10>] ? USBD_InterfaceSubmitIsoOutUrb+0x0/0x30 [ndiswrapper]
[  179.738844]  [<ffffffffa02cebe0>] ? USBD_InterfaceQueryBusInformation+0x0/0x30 [ndiswrapper]
[  179.738888]  [<ffffffffa02ceae0>] ? USBD_InterfaceIsDeviceHighSpeed+0x0/0x20 [ndiswrapper]
[  179.738932]  [<ffffffffa02c152c>] ? ExAllocatePoolWithTag+0x3c/0x80 [ndiswrapper]
[  179.738978]  [<ffffffffa02d072b>] ? win2lin3+0x11/0x14 [ndiswrapper]
[  179.739034]  [<ffffffffa02cc90f>] ? mp_init+0x6f/0x200 [ndiswrapper]
[  179.739079]  [<ffffffffa02c6cd2>] ? pdoDispatchPnp+0x42/0x100 [ndiswrapper]
[  179.739123]  [<ffffffffa02cde5c>] ? ndis_start_device+0x2c/0x8b0 [ndiswrapper]
[  179.739166]  [<ffffffffa02c3dfd>] ? IofCallDriver+0x6d/0xd0 [ndiswrapper]
[  179.739220]  [<ffffffffa02c3dd1>] ? IofCallDriver+0x41/0xd0 [ndiswrapper]
[  179.739263]  [<ffffffffa02c43b6>] ? IoSyncForwardIrp+0x96/0xd0 [ndiswrapper]
[  179.739308]  [<ffffffffa02ce783>] ? NdisDispatchPnp+0xa3/0x150 [ndiswrapper]
[  179.739353]  [<ffffffffa02d0717>] ? win2lin2+0xe/0x11 [ndiswrapper]
[  179.739396]  [<ffffffffa02c3dd1>] ? IofCallDriver+0x41/0xd0 [ndiswrapper]
[  179.739438]  [<ffffffffa02c3dfd>] ? IofCallDriver+0x6d/0xd0 [ndiswrapper]
[  179.739489]  [<ffffffffa02c3dd1>] ? IofCallDriver+0x41/0xd0 [ndiswrapper]
[  179.739532]  [<ffffffffa02c5dad>] ? IoSendIrpTopDev+0xdd/0x130 [ndiswrapper]
[  179.739583]  [<ffffffffa02c3c18>] ? IoAttachDeviceToDeviceStack+0x68/0x80 [ndiswrapper]
[  179.739627]  [<ffffffffa02c61ac>] ? pnp_start_device+0x4c/0x90 [ndiswrapper]
[  179.739671]  [<ffffffffa02c6479>] ? wrap_pnp_start_device+0xf9/0x180 [ndiswrapper]
[  179.739715]  [<ffffffffa02c65f1>] ? wrap_pnp_start_usb_device+0xf1/0x120 [ndiswrapper]
[  179.739852]  [<ffffffffa02f1000>] ? wrapper_init+0x0/0xb0 [ndiswrapper]
[  179.739888]  [<ffffffffa02b7e4f>] ? loader_init+0xcf/0x160 [ndiswrapper]
[  179.739920]  [<ffffffffa02f107b>] ? wrapper_init+0x7b/0xb0 [ndiswrapper]
[  179.740020] RIP  [<ffffffffa02ceae9>] USBD_InterfaceIsDeviceHighSpeed+0x9/0x20 [ndiswrapper]

After I run that command, anything to do with ndiswrapper pretty much sends me into an infinite loop. Like, for example, ndiswrapper -lnever returns anything.

Does anybody have any idea why?? I think it might be a blacklist issue but it's my understanding that I would only have to blacklist a built-in wireless driver. Is that right? What am I doing wrong? And what can I do to fix it? Any help would be very much appreciated.

Update - more information

uname -rp

compaq@ubuntu:~$ uname -rp
2.6.32-38-generic unknown

Entering lsusb sends me into an infinite loop.

compaq@ubuntu:~$ lsusb

Before I install ndiswrapper and run sudo modprobe ndiswrapper lsusb works fine. I remember it does list my Netgear, Inc device and gives me 0846:9011.

share|improve this question

closed as off-topic by Seth Jun 23 at 23:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

    
We need a bit more information. Please add: uname -rp as well as: lsusb. –  chili555 Nov 16 '12 at 11:36
    
@chili555 added more info. Thanks for having a look. –  user1570359 Nov 16 '12 at 15:55
    
You have an older version of Ubuntu and and older version of ndiswrapper: 1.55. I think you'd have a much better chance with a newer version, at least 12.04 LTS using ndiswrapper 1.57 by default. On Ubuntuforums, very few have had success with 64-bit which it appears you have; at least the .inf file is for 64-bit. (bcmn43xx64) –  chili555 Nov 16 '12 at 21:04
    
I updated to 12.10 and everything is working fine. Thanks chili555! –  user1570359 Nov 18 '12 at 22:00