Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  1. I removed OpenOffice with isuru@isuru-desktop:~$ sudo apt-get purge "openoffice*"
  2. Now when I try to install LibreOffice I get following error enter image description here

Please help me to install LibreOffice on my computer. Im om Ubuntu 10.04

share|improve this question
    
Have you tried sudo apt-get update? –  Josua Schmid Nov 16 '12 at 8:11
    
If you are still using 10.04 LTS, then there is a stable version of OpenOffice.org (pre Apache OpenOffice, pre LibreOffice) that works fine. –  david6 Nov 19 '12 at 10:56
    
OpenOffice.Org is bit slower than libre. That's why i'm switching. –  isuru-buddhika Dec 19 '12 at 11:45

3 Answers 3

oooh mate what you have done....

In debian apt is wonderful command and play with it careful. Now as i understand your scenario. You are trying to remove your Office package. Remove packages from synaptic or software-manager is kind of easy, but through apt it might create problem sometime.

Before doing anything with apt, please take backup of /var/lib/dpkg/status and /var/lib/dpkg/avialable file. If anything goes wrong these files will help you to recover your apt correctly.

For Remove Libreoffice (complete)

sudo apt-get purge libreoffice*

sudo dpkg --configure -a

As you know libreoffice package contains lot of other libreoffice packages like libreoffice-draw libreoffice-writer etc. So you have to put libreoffice* (* represent all packages who start with libreoffice and end with anything).

NOTE: if dpkg --configure -a give you any error then you have to remove these packages one by one with

dpkg --purge package-name

Hope it will fix your issue.

share|improve this answer

It looks your your apt cache is out of date.

run sudo apt-get update then sudo apt-get install libreoffice

If that still doesn't work then edit your software sources and remove any PPAs or experemental repositories so your back to just the default ones and try again.

The best way to remove "extra" repositories is with "software sources" from inside the System settings.

share|improve this answer

I've same problem and this works for me

http://ubuntuforums.org/showthread.php?t=2082867&page=2

share|improve this answer
1  
Please provide the detailed steps to help everybody know the answer better. –  smartboyhw Dec 13 '12 at 13:50
    
Try to be more descriptive in the answer –  VedVals Dec 13 '12 at 13:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.