Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed the latest version of Ubuntu (12.10). I then installed Gnuplot with this command:

sudo apt-get install gnuplot

However, now whenever I run Gnuplot it says

terminal set to 'unknown'

On my old installation of Ubuntu (12.04) it worked and would set the terminal to 'wxt'.

Any idea why it doesn't set it to the correct terminal?

Also,set terminal wxt doesn't work either.


share|improve this question
up vote 26 down vote accepted

Just add gnuplot-x11 package via the terminal (CTRL+ALT+T):

sudo apt-get install gnuplot-x11

or via the software-center:

Install via the software center

share|improve this answer
Welcome to askubuntu and thanks for your answer! Your future answers will be perfect if you add instructions for beginners (e.g. how is the package added?). This way nearly everyone can follow your answer and you reach a lot more help seeking users. – mrcktz Nov 22 '12 at 19:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.