Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It used to be gnome-power-manager or something of that sort, but now I can't seem to find it. When I run gnome-session from within awesome, it loads all the applets, i.e. nm-applet and the keyboard layout switcher, yet it doesn't load the battery applet, and so I'd like to launch it with a command.

share|improve this question
    
Try gnome-settings-daemon –  devav2 Nov 16 '12 at 10:45
    
@devav2 Gnome-session launches gnome-settings-daemon, so I'm already running it. It doesn't add a battery indicator to my system tray, which is why I need to find the command. –  Jon Nov 16 '12 at 18:20
    
possible duplicate: check out the 2nd comment. askubuntu.com/questions/148971/… –  Suhaib Nov 24 '12 at 20:51
    
@Suhaib No, the issue is not that the battery indicator doesn't show up under certain conditions (e.g. when charging), but rather that it doesn't exist at all. This problem would be solved if I knew the command to run the applet. –  Jon Nov 25 '12 at 21:51
    
My problem is that I don't want the integrated indicator since it has components I never use, but I can't find a stand-alone applet for newer Ubuntus... –  lukstafi Apr 12 at 8:00

3 Answers 3

You should be able to restore the menu-bar icon by using the Dconf editor. This is probably already installed, but if not, it's in the Sofware Center as Dconf Editor. Note that's a title not the package name. In Synaptic it's dconf-tools. The command line is sudo apt-get install dconf-tools.

This is a low-level editor for system settings, so be careful.

To get to the power icon setting:

com --> canonical --> indicator --> power. After clicking power, look for "icon-policy" in the right pane. Presumably it will say "never." Change it to "present"

share|improve this answer
    
"icon-policy" already says "present." –  Jon Feb 2 '13 at 20:49

the default battery indicator in ubuntu is part of the 'unity-panel-service' it's called 'indicator-power' and can't – as far as I know – be called on its own.

However you can try to install 'indicator-applet' and then 'indicator-power' if it's not already installed. And then try launching 'indicator-applet' and see what you end up with.

Sorry for bad formatting my cell phone somehow doens't get the spacing for the code right

share|improve this answer

First Install Battery-Status by Running following command in terminal.

sudo add-apt-repository ppa:iaz/battery-status && sudo apt-get update
sudo apt-get install battery-status

To run ‘Battery Status’ as an Indicator-applet in Ubuntu you’ll need to run the following command in a terminal:

/usr/lib/battery-status/battery-status --indicator

To launch the indicator mode on log-in add it to your ‘Start-up applications’ in System > Preferences > Startup Applications, entering the command above in the command field.

share|improve this answer
    
The PPA maintainer hasn't built battery-status for 12.10, so I get E: Unable to locate package battery-status. Isn't there a default battery indicator command that doesn't require adding a PPA? –  Jon Nov 16 '12 at 18:19
    
Yes, You are right, I checked out. You have to wait for that. –  K.K Patel Nov 17 '12 at 3:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.