Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to stream the output from Pulseaudio to my WDTVLive Streaming Media Player using Rygel. I have been playing around with it for a while, looking around forums/blogs etc and I’m getting closer but I can't quite get it running (I've been using Ubuntu for a few years but still a relative novice). Currently I am getting the following errors when I run Rygel in a terminal:

Rygel-Tracker-Message: rygel-tracker-plugin-factory.vala:33: Plugin 'Tracker' disabled by user, ignoring.
Mediathek-Message: rygel-mediathek-plugin.vala:33: Plugin 'ZDFMediathek' disabled by user, ignoring..
MPRIS-Message: rygel-mpris-plugin-factory.vala:33: Module 'MPRIS' disabled by user, igoring…
External-Message: rygel-external-plugin-factory.vala:33: Module 'External' disabled by user, igoring…
MediaExport-Message: rygel-media-export-plugin.vala:32: Plugin 'MediaExport' disabled by user, ignoring..
Rygel-Message: New plugin 'GstLaunch' available

(rygel:6727): Rygel-CRITICAL **: Error from pipeline RygelHTTPGstResponse: pulsesrc.c(1480): gst_pulsesrc_prepare (): /GstPipeline:RygelHTTPGstResponse/GstBin:bin0/GstPulseSrc:pulsesrc0 

(rygel:6727): Rygel-CRITICAL **: Error from pipeline RygelHTTPGstResponse: pulsesrc.c(1480): gst_pulsesrc_prepare (): /GstPipeline:RygelHTTPGstResponse/GstBin:bin1/GstPulseSrc:pulsesrc1 

(rygel:6727): Rygel-WARNING **: rygel-http-request.vala:97: Invalid seek request

(rygel:6727): Rygel-WARNING **: rygel-http-request.vala:97: Invalid seek request

(rygel:6727): Rygel-WARNING **: rygel-http-request.vala:97: Invalid seek request

The final error seems to repeat indefinitely. I can see the stream on both my WDLive player, and also using BubbleUPNP on my phone, however I cannot hear any audio on the device and my WDTV seems to think the format is not supported (I checked and encoding to FLAC as I am doing is apparently supported. I have also tried other formats with the same result. Currently on Ubuntu 12.10 and Rygel 16.0.2

Hope someone can help. Thanks.

share|improve this question
    
Somehow related: askubuntu.com/questions/187086/… –  Takkat Nov 16 '12 at 7:23

1 Answer 1

up vote 0 down vote accepted

In Ubuntu 12.10 Rygel didn't work for me as well for this purpose. Since then now I use Ubuntu 13.10, and Rygel has been updated to version 20, which works for me flawlessly. This GNOME Wiki! article tells us that Rygel has two PPAs:

Both has packages back to Precise of Rygel, so if you are still using 12.10, and those repositories do not have Rygel version 20, then you might want to try using these PPAs.

Also, if something else would be the problem, here's my config to compare:

[GstLaunch]
enabled=true
title=@REALNAME@'s stream
launch-items=myaudioflac;myaudiompeg

myaudioflac-title=FLAC audio on @HOSTNAME@
myaudioflac-mime=audio/flac
myaudioflac-launch=pulsesrc device=upnp.monitor ! flacenc

myaudiompeg-title=MPEG audio on @HOSTNAME@
myaudiompeg-mime=audio/mpeg
myaudiompeg-launch=pulsesrc device=upnp.monitor ! lamemp3enc target=quality quality=6

[Playbin]
enabled=true
title=Audio/Video playback on @REALNAME@'s computer

[general]
interface=

[MediaExport]
uris=@MUSIC@;@VIDEOS@;@PICTURES@;
share|improve this answer
    
Works great. Thanks –  user99062 May 18 at 3:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.